cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BrianWarriner
New Member

Collections is blank

Hello,

  I'm using a O365 connection.

This is the collection statement...

Set(endTime,Now());Collect(InfoSecA10Qs,{User:User().FullName,Email:User().Email,Score:scoreVal,Started:startTime,Ended:endTime})

 

If I run the app from where I'm creating it, I can see my information populate. If it is run from a browser with my credentials or another who I have shared the app with, it will not collect anything.

 

Please help.

10 REPLIES 10
WarrenBelz
Super User
Super User

Hi @BrianWarriner ,

Assuming that the scoreVal, startTime and endTime Variables exist, there is nothing wrong with that code. I just ran it here in both design and Play and it worked fine.

Hi @BrianWarriner,

 

Could be a problem with your browser?, could you cleanup your browser cache in that case...?

 

Please give it a thumbs up if it helped in some way...

 

Cheers,

PMDY

Clear cache in Edge first and then tried in I tried in different 2 browsers. Edge and Chrome. Same results. Odd that it would when working within the suite but when I go to play it in a browser it won't.

Clear cache in Edge first and then tried in I tried in different 2 browsers. Edge and Chrome. Same results. Odd that it would when working within the suite but when I go to play it in a browser it won't.

Clear cache in Edge first and then tried in I tried in different 2 browsers. Edge and Chrome. Same results. Odd that it would when working within the suite but when I go to play it in a browser it won't.

If you want to check, you  could add a clear collect statement before your collect statement. I believe there was no issue with your logic, just add clearcollect and try if it works...I still wonder why not working for you as did for @WarrenBelz .

 

Cheers,

PMDY

 

 

Yes. I have done that. Clearing the colection and it had the same result.

I'm wondernig if it is a licinzing issue. We have standard licensing. Should we be using E3? I'm kind of guessing at it.

@BrianWarriner ,

If the user can open the App, it is not an authority/permissions issue as it is not accessing any data.

What could be the possible reason that it can't write to the collection? It can within building the app and testing the data is there but not through the browser. That is what has me stumped.

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (3,363)