cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate III
Advocate III

ComboBox result not displaying on Form Edit/View modes

Good day...

I've got a SharePoint list from which I've created a powerapps form for

One of my SP List fields is a Single Line of Text, I've inserted a Combo Box Linked to another SP List for selection in this form.

All works well, and the Combo Box saves/passes the selected choice/record into my SP List when saving/submitting the form.

However when opening the same SP list item in Edit or View modes, the Combo Box shows "Blank" value, even though the field holds and actual value when checking on my list.

Below are the formulas I'm using, for reference

1. Items

SortByColumns( Distinct ('01. CASH_SERVICES', SERVICE ), "Result" , Ascending)

2. DisplayMode

If(IsBlank(MODIFIERVALUE_SERVICES.Text), DisplayMode.Edit, DisplayMode.View)

3. DisplayFields

["Result"]

This is how it looks like in the "Form.New" mode:

new.png

 

This is how it looks like in the "Form.Edit or Form.View" modes:

edit.png

1 ACCEPTED SOLUTION

Accepted Solutions

Hey @Luka84 

 

Can you try to update the DefaultSelectedItems property of the combobox control to:
 
Expression: [Parent.Default]
 
If you get any error using this expression, please share the error details.
 
Hope this Helps!
 
If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

4 REPLIES 4
Advocate III
Advocate III

I suspect it has something to do with "Default" property

I tried "Parent.Default", but it returns an error.

Might not be the issue, but worth the thought

Hey @Luka84 

 

Can you try to update the DefaultSelectedItems property of the combobox control to:
 
Expression: [Parent.Default]
 
If you get any error using this expression, please share the error details.
 
Hope this Helps!
 
If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Hi @yashag2255 

I knew it was simple, just didn't know the context - thank you sir

I tried Parent.Default without the brackets and it didn't work, drove me crazy !!

I'm laughing, because I just went crazy for the last 2 days!   Thanks...this solved it for me.  

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (9,478)