cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
miss_haley
Helper I
Helper I

Combobox search wildcard

Hi, 

 

Previously when I created a combobox to test with Item Property: ["pineapple", "pinecone", "pine", "apple"] I was able to search for "pin" and pineapple, pine, pinecone is return in dropdown or "apple" will show apple and pineapple in dropdown.

 

Now I connect the combobox to my SP list I was not able to search the same way - I have to type the pattern in exact order else nothing shows up. 

 

My SP list contains the same choices behind it. 

 

Is there a work around for this so that I can search for wildcards ?

1 ACCEPTED SOLUTION

Accepted Solutions

8 REPLIES 8
WarrenBelz
Super User III
Super User III

Hi @miss_haley ,

Not sure what your issue is - see below

SearchCB.gif

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

Hi @WarrenBelz 

I am not sure how to make a gif to give example but hopefully my screenshot can explain.

 

Here I have a list of branches, there are three options which has "Cross Dock" in them.

 

search button.PNG

 

When I type in "Cross" nothing shows up:

search cross.PNG

It only works if I start with exactly the same letters

Capture2.PNG

 

How can I make it so it doesn't do exact matches and function like your gif example?

@miss_haley

That will work until you get more than 2k items In the list.  

hi @Drrickryp do u have an alternative I do have another column with 1400 choices.

Hi @miss_haley ,

Agree with @Drrickryp , however you should not need to do that to get the result.  The in filter is not Delegable, although I am surprised your current filter did not work if you have your limit in Advanced Settings set to more than the number of items you are searching.

I have just done a test on a 2000 item drop-down and got a search result as expected. I assume you have "Allow Searching" turned on the in the Combo Box.

Search2000.gif

@WarrenBelzThanks for testing and replying to me.

 

I have change settings as you said - but the search still only does exact match from the start. It is strange because few days ago this was working fine. Maybe I broke something in the app - but for the moment I will use the filter solution as I am on a limited time frame to give this solution. 

 

I just started to use power apps so I am unsure how to tackle these problems. 

 

@miss_haley- Are you by any chance in a GCC tenant? I have the same problem doing searches in combo boxes. The solution you found works perfectly for me, so thank you for that find! Since my list won't go above 50 I'm not concerned with size.

 

Thanks,

Jon

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (46,893)