cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Combobox selected property not available in live (published) application

Hello,

 

I builded an app where I need to use two comboboxes to use for filtering; I can't use dropdown control, one of the list has nearly 900 items and dropdowns don't have the search feature.

 

Both combobox are single-selection control.

 

In the development environment, everything works flawlessly. So I went ahead and published the app and retest it in the live environment. The combobox no longer return a selection after a choice is made.

 

So I added two text fields to show what is being selected in the Onchange events of the controls, it seems like the seletected proterty is not operating in published apps.

 

Here is the behavior in DEV, I seletect an item in the brand combobox, the counter text field shows 1 and the selected item value is 1676. Similar for the category, 1 selected and the internal value is 162:

powerAppsComboDev1.jpg

 

Once deployed, this is what is happening, the counter will report that an item was indeed selected, but no value is passed to the selected property:

powerAppsComboLive1.jpg

 

Here is the code that handles updating the two fields:

UpdateContext({BrandCount:CountA(BrandFilter.SelectedItems.name)});
UpdateContext({AccountNo:BrandFilter.Selected.kdc_accountNo});

 

Are single-selection combobox really supported? It doesn't seems so. Why the different behavior?

 

I would really appreciate any help with this issue as I was really close to publishing the application.

 

Thanks!

 

Eric

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Hello,

 

Found a solution for my case of the problem in thi thread:

https://powerusers.microsoft.com/t5/Building-Power-Apps/ComboBox-Selected-value-Works-in-Preview-but...

 

In Settings, I turned off "Explicit column selection".

View solution in original post

1 REPLY 1
Highlighted
Helper I
Helper I

Hello,

 

Found a solution for my case of the problem in thi thread:

https://powerusers.microsoft.com/t5/Building-Power-Apps/ComboBox-Selected-value-Works-in-Preview-but...

 

In Settings, I turned off "Explicit column selection".

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (12,555)