cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
IDK_DUDE
Frequent Visitor

Combobox to power automate not working

Hello,
I'm trying to connect power automate to power apps, but I can't pass the value of Combobox to power automate. The error I get can be seen in the attachements. I've tried SelectedItems and Selected.Value functions, but none of them work. Finally I tried text function to kinda convert combobox values into text but it doesn't work as well. Any help will be appreciated. 

1.PNG

2.PNG

3.PNG

4.PNG

    

1 ACCEPTED SOLUTION

Accepted Solutions

Its searching for emails from sharepoint. It's multi select and yes it's definitely a combobox.

View solution in original post

15 REPLIES 15
C-Papa
Super User
Super User

Hi, its probably because its multi select. you need to use the concat function to put it into a string, emails should be separated by ";"

Combobox is attached to SharePoint so E-mail data is changed daily. How can I separate e-mails in a situation like this?

 

C-Papa
Super User
Super User

just change you run. Email1.SelectedItems to Concat(Email1.SelectedItems, Email, ";") and it should work. what are your trying to achieve in flow? just send and email?

 

 

Creating Teams meeting. Should I use your code with combobox code or with button code when I connect the power automate flow?

C-Papa
Super User
Super User

ok, i wouldn't do it the way your are doing it, i would change your flow trigger to when a new item is created in SharePoint or updated (what ever you prefer), this way PowerApps doesn't have to interact with PowerAutomate and PowerAutomate can get the record straight from the data source, this means you can add the Email column with multiple people selected straight into the teams meeting connector

No, I need this to deduct the remaining hours from Sharepoint. So when I schedule the meeting I will get the info of duration and remove hours depending on user. That's why I use initialize variable for meeting scheduling.

Thanks, Concat works, but in power automate my output looks like this. Any fix?

IDK_DUDE_0-1644477649060.png

 

C-Papa
Super User
Super User

what does it look like in the PowerApps connector / the trigger? you don't need to use the initialise variable / set variable function as it should already be a string coming from PowerApps, therefore you don't need to create the string again, 

 

the emails should come through looking like "email1@email;email2@email; etc"

The whole thing looks like this:Capture.PNG1.PNG

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (2,966)