cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Comboboxes Are Not Saving To SharePoint List

Hi folks,

I’ve searched this problem quite a bit this AM and have found related issues but none that seem to map directly onto mine – and no solutions that have worked for me so far.  A caveat, I am rather new to Power Apps so could be missing something.

 

Issue Background:

  • I have a SharePoint list with some existing form entries.
  • I created a Power Apps form to replace the “out of the box” form, focused only on easier viewing/organization of the data fields.
  • I want my users to be able to open the forms from the SharePoint list, for those forms and the associated data to open in the Power Apps form for easy viewing/editing, and that when they save/close the Power Apps form that the data save back into the SharePoint list.

 

Issue:

  • The forms mostly work as expected, all data is pulled from the existing forms into my Power Apps form for viewing/editing, and most is saved back to the SharePoint list when edited/saved.
  • However, if I edit any combobox fields (i.e. choice fields, name lookups) the changes do not save to my SharePoint list, and also don’t appear when I reopen the form in Power Apps.
  • Otherwise, the combobox fields appear in the form as you would expect, with all of the expected choices in the dropdown menus.  I can select the choices and they will populate in the field – simply will not save to the underlying SharePoint list.

 

Other Info:

  • When I first created the list, there were no errors in the Power Apps canvas.
  • When I logged in today, all of my comboboxes were giving me errors “the data source supplied to this function is invalid”.
  • I didn’t change anything about the form or the underlying SharePoint list.
  • When I refreshed the data source the errors disappeared, but the issue above persisted.

 

Any help would be appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
Regular Visitor

Hi @WarrenBelz - apologies for the delayed replay, busy couple of weeks!

It actually ended up being an issue related to have multiple cards for a single form; my staff were entering data in one card, clicking next, and entering more data, but the data from the previous card was not saving - and it was only effecting comboboxes for some reason.

 

Thanks for your help!

View solution in original post

5 REPLIES 5
Super User III
Super User III

Hi @PugGeorge ,

Please pick one of the non-working combo box and supply (in Text) the following

Items and DefaultSelectedItems of the Combo Box

Update of the DataCard it is in

The name and type of field you are trying to write back to.

Hi @WarrenBelz ,

 

Thanks for your reply - the information that you requested:

 

Items = Choices([@'CRPS Database'].Urgency)

 

DefaultSelectedItems = Parent.Default

 

Update = DataCardValue28.Selected

 

Name of field that I'm writing back to = "Urgency"

Type = Choice

 

Happy to provide any further info that might help. 

 

Thanks

 

 

Hi @PugGeorge ,

Try this

Items = Choices([@'CRPS Database'].Urgency) - OK

DefaultSelectedItems = Parent.Default - OK if displaying otherwise try ThisItem.Urgency

Update = DataCardValue28.Selected   - Needs to be

{Value:DataCardValue28.Selected.Value}

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

Hi @PugGeorge ,

Just checking if you got the result you were looking for on this thread. Happy to help further if not.

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Regular Visitor

Hi @WarrenBelz - apologies for the delayed replay, busy couple of weeks!

It actually ended up being an issue related to have multiple cards for a single form; my staff were entering data in one card, clicking next, and entering more data, but the data from the previous card was not saving - and it was only effecting comboboxes for some reason.

 

Thanks for your help!

View solution in original post

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (33,473)