cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Robert14356
Resolver I
Resolver I

Component Libraries not working

Hello Everyone.

 

I have a Navigation Bar component that refuses to work in other apps, but works flawlessly in itself..

 

The properties on the component are all dynamic and it seems to forget the height of a sub gallery constantly when its republished and added into an app.

 

Is this quite common in components? should i just make this inside the individual apps itself?

8 REPLIES 8
Jcook
Super User
Super User

Hello @Robert14356 

 

What is broken about the navigation bar? Is it just the height?


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





The Height of objects and some objects don't even show up.

@Robert14356 

And the height is also dynamic? What is the expression your using?


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Robert14356
Resolver I
Resolver I

Countsrows(Thisitem.Submenu) * 40

@Robert14356 
How are you defining the items properly inside your component for the gallery?

 

I think some screenshots will help not only me but others to.

could you share what the component looks like in your library. And what it looks like inside a app.

 

thanks 


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Robert14356
Resolver I
Resolver I

The property is in the subgallery, which is not an input by the user.

 

in Library                                                 in App

Capture1.JPGCapture2.JPG

 

 

Robert14356
Resolver I
Resolver I

I copy pasted the thing from the library into the app, and the gallery is fine.

 

Its the items inside the Gallery, all the heights of the items aren't saving for some reason.  Most of them are just numbers only 2 of them are formulas.

 

the formulas are saving but the just plain numbers aren't, they are defaulting to 1 (width/height).

 

 

ShantanuP
Power Apps
Power Apps

@Robert14356 

Just to confirm that I understood the issue. You have following structure in component in library

 

Gallery

  ---- Gallery

           -- Some labels

 

After importing this component in app, the height of certain controls inside the gallery change. Have you tried this in published app or only during authoring?

Creating a local copy of that component inside an app, things work fine.  Have you tried this in published app or only during authoring?

 

Which height rules are not preserved and keeps changing after importing component in app. Has this ever worked before? Would it be possible for you to share library msapp which produces the issue with me? If not then what are the steps to reproduce this issue on my side?

 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (4,097)