cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KC Continued Contributor
Continued Contributor

Components - Issues when using grouped controls in the Published App

PowerApps version: 3.19021.13

 

Canvas App -

Some Component controls fail to show in the Published app.

Steps to repeat:

  1. Create a Component
  2. Place 2 Labels, an Icon and Radio Button controls on the canvas
  3. Place the Component on the canvas of an app
  4. Publish
  5. View by launching from the Designer or on a device or launch in a Browser from the Environment screen or Dynamics 365 - the 2 Labels, Icon and Radio Buttons are Visible
  6. In the Component group the Labels, Icon and Radio Buttons
  7. Publish the app
  8. View on a device or launch in a Browser from the Environment screen or Dynamics 365 - the 2 Labels are Visible, the Icon and Radio Buttons are NOT Visible. 

 

Some Component controls become unusuable in the Published app and formulas may not be activated as expected.

Steps to repeat:

  1. Create a Component
  2. Place a Text Input control on the canvas
  3. Place a slider control on the canvas
  4. Place a toggle button on the canvas
  5. Save and Publish
  6. View by launching from the Designer or on a device or launch in a Browser from the Environment screen or Dynamics 365
  7. The controls are visible and accessible
  8. Back in the component, group the text control, slider and toggle button
  9. View by launching from the Designer or on a device or launch in a Browser from the Environment screen or Dynamics 365
  10. Click the toggle button, it should switch to On
  11. Click the toggle button once more, it stays in the On position, it is now in-accessible
  12. The text input and slider are still accessible.
4 REPLIES 4
Power Apps
Power Apps

Re: Components - Issues when using grouped controls in the Published App

@KC 

Re: components not showing

  • Do you see the controls when they are not grouped?
  • Are you using the enhanced group control or the original group control?
KC Continued Contributor
Continued Contributor

Re: Components - Issues when using grouped controls in the Published App

 

  • Do you see the controls when they are not grouped? Yes
  • Are you using the enhanced group control or the original group control? Both have the issue. I deleted the enhanced group control, then grouped the controls normally and they still would not show in the published app. They will only appear if ungrouped.
Power Apps
Power Apps

Re: Components - Issues when using grouped controls in the Published App

Hi @KC, can you try to turn off "formula-level error management" in App setting to see if it is the cause? There seems to have issues with this feature turned on.

Highlighted
KC Continued Contributor
Continued Contributor

Re: Components - Issues when using grouped controls in the Published App

@yfw I turned the "formula-level error management" off due to another issue.

I grouped the controls normally and they still would not surface.

 

I then turned the "enhanced group control" off in App Settings and grouped the component controls once more with the normal Group.

They are now visible when I launch the app.

 

I turned the "enhanced group control" back on and the component controls are still visible.

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (6,083)