cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Components Performance - Inefficient Loading

I’m getting a lot of performance warnings related to components in the studio when running the check app function.  Not sure if the issue is with my component, my app, or if there is a bug with the app checker.

The performance warnings state that there is inefficient loading because there is a reference to a different screen.

 

I have double checked everything and don’t see anything that references controls or properties on a different screen.

 

For example, I have a left navigation component on every screen.  In the component, there is a hamburger icon that sets a Boolean variable in the component called varMenuOpen. The component has an number output property called MenuWidth.

 

The MenuWidth output property is set to A formula.

 

If(varMenuOpen, Max(App.Width, App.DesignWidth)/5+80, 70)

 

On the app screen, the Width of the component is set to it’s MenuWidth output property.

 

This works just like a charm.  Clicking the hamburger in the component triggers the components variable, which then sets the width of the component according to the formula.

 

But I am getting performance warnings about referencing the MenuWidth output property of each component in the app.  The warnings state that there is an inefficient load caused by referencing controls on other screens. This is where I’m confused because there is nothing referencing a different screen with that property.

 

Not sure if the issue is with my component, my app, or perhaps the Studio’s app checker giving a false positive. Anyone have any insight?

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Components Performance - Inefficient Loading

Hi,

 

Looking at this, I cannot figure out why you are getting this error. It seems like it should be working fine and it appears that it is. It just keeps throwing this warning despite there being nothing wrong. I would suggest opening a case with Microsoft Support on this. I'll include a link if you would like to go down that path. Otherwise if any other communities members might know what is going on here feel free to chime in.

 

If you would like to create a ticket with Microsoft Customer Support here is a link on how to do so: https://docs.microsoft.com/en-us/power-platform/admin/get-help-support

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
Frequent Visitor

Re: Components Performance - Inefficient Loading

The same thing is happening to me.  Did you ever contact Microsoft and get an answer?

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (9,928)