cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Connor_Taylor
Resolver I
Resolver I

Conditional statement working only SOMETIMES

Hey all, 
So I have a powerApp that:

If(CurrentUser.FullName in '[dbo].[PAR_Comments_Submission]'.User_Submitted,Exit(true), SubmitForm(Form1))

Basically
 - On a timer end 
 - Takes the users fullname 
 - Checks if it is already in the database
 - If it is the app exits
 - If it isnt submits a form 

The problem is this only works SOMETIMES
Sometimes the app exits when the users detials are already in the database  (as inteneded) 
Other times it will still stubmit the form even though the data is already there

Any help appreciated,
Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Drrickryp
Super User II
Super User II

Hi @Connor_Taylor,

One reason that the function only works part time could be due to delegation issues related to the “in”  function which is not delegatable.  Instead please try a combination of IsBlank() and Lookup() to test for inclusion. Lookup() is a delegatable function.

View solution in original post

3 REPLIES 3
Drrickryp
Super User II
Super User II

Hi @Connor_Taylor,

One reason that the function only works part time could be due to delegation issues related to the “in”  function which is not delegatable.  Instead please try a combination of IsBlank() and Lookup() to test for inclusion. Lookup() is a delegatable function.

View solution in original post

Hi @Drrickryp,

 

This approuch was working for most but still seems to only work sometimes on others

This was my updated statement

If(Not(IsBlank(LookUp(PowerBIIntegration.Data, Value = 39).Value)) ,NewForm(Form1);Navigate(Sub,ScreenTransition.Fade),If(Not(IsBlank(LookUp(PowerBIIntegration.Data, Value = 40).Value)),Navigate(Screen2,ScreenTransition.Fade),NewForm(EditForm1);Navigate(BrowseScreen1_1,ScreenTransition.Fade)))

Basically:
 - If the value is 39 THEN navigate to a form page
 - If the value is 40 THEN navigate to a different page
 - Else navigate to a different page

But this only works sometimes, as if the conditional statements are ignored and navigates to the 'Else' page.

Can you think of how to fix this?

Thank you

Edit: Whoops - sorry I replied to the wrong thread.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (46,678)