cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cha_cha
Solution Sage
Solution Sage

Control not updating if the screen is not active

Hello all!

 

I encountered this issue just today. This normally worked before. So here are the details:

 

I have a Branding screen where I put all my settings like colors and stuff. So the settings are dependent on a variable that I update across the app. This has been my setup for the past few apps since learning about the method. 

 

Today, I'm making a new one and suddenly the controls on the branding screen are not updating unless I go to the actual screen and update the variable there.

 

Has anyone experienced this too?


 
Just in case you my answer helped you solve your problem, please mark/accept this as a SOLUTION This helps community members if they experience a similar issue in the future.

 
bistek.space   @cha_bistek    @BisTekSpace 
1 ACCEPTED SOLUTION

Accepted Solutions
cha_cha
Solution Sage
Solution Sage

Okay, so after giving up, posting here, and continuing with my app, it's now updating.

 

The trick was to add other control to my screen that is also dependent on the control properties in the branding screen. Earlier, the screen that I have been working on only has components on it, not actual controls like Rectangle. so far it worked.

 

I also experimented on the FillColor of my screen to be dependent on a control from the branding screen and it worked. I think that was it.


 
Just in case you my answer helped you solve your problem, please mark/accept this as a SOLUTION This helps community members if they experience a similar issue in the future.

 
bistek.space   @cha_bistek    @BisTekSpace 

View solution in original post

1 REPLY 1
cha_cha
Solution Sage
Solution Sage

Okay, so after giving up, posting here, and continuing with my app, it's now updating.

 

The trick was to add other control to my screen that is also dependent on the control properties in the branding screen. Earlier, the screen that I have been working on only has components on it, not actual controls like Rectangle. so far it worked.

 

I also experimented on the FillColor of my screen to be dependent on a control from the branding screen and it worked. I think that was it.


 
Just in case you my answer helped you solve your problem, please mark/accept this as a SOLUTION This helps community members if they experience a similar issue in the future.

 
bistek.space   @cha_bistek    @BisTekSpace 

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (5,066)