cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Controls disappear during development

Hi,

 

My app has a hidden popup screen that is shown with a variable and visibility when I click on a button on the main form.

During development, half of the controls (buttons and the checkbox and some labels) disappear when I Preview it. It makes it VERY hard to debug and dev.

 

If I PUBLISH the app, it seems to work fine. This is obviously not a solution as I cannot publish the app every 5 minutes during my Dev cycle to test it. 

 

Here's a screenshot of the popup window in a published version (apologies it is under NDA so many things are blurred out)

 

9jqUAW8

 

and then here is the SAME popup window when previewed during Development. The Red boxes indicate the missing controls.

 

The z-order is correct (the Popup is at the very front) and all the controls have their Visible property set to the same field - I am convinced it is a PowerApps bug.

 

Thoughts?

 

0lEcUK5

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @rodneyjoyce ,

Do you mean that some of your controls disappear when preview?

I've made a similar test but not met the same problem like your description.

Here's my test for your reference:

1)I create a popup window based on your layout:

a Rectangle, three labels, a radio, two buttons

2)Group these controls together

551.PNG

 Please notice the controls' order and fill.

They may be covered by each other.

3)insert a button to make the popup window display/disappear.

set the button's OnSelect:

Set(var,!var)

 set group1's Visible: var

 

Then if I click the button , the popup window will display. If I click twice, the popup window will disappear.

All the controls are changing together.

(Both my preview mode and running mode, the app works good.)

55.gif

 

 

 

If your problem still exists, please show me your settings about these controls and the button to make them visible.

Actually, I think your key problem is about order and fill. Please check these firstly.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Community Support
Community Support

Hi @rodneyjoyce ,

Do you mean that some of your controls disappear when preview?

I've made a similar test but not met the same problem like your description.

Here's my test for your reference:

1)I create a popup window based on your layout:

a Rectangle, three labels, a radio, two buttons

2)Group these controls together

551.PNG

 Please notice the controls' order and fill.

They may be covered by each other.

3)insert a button to make the popup window display/disappear.

set the button's OnSelect:

Set(var,!var)

 set group1's Visible: var

 

Then if I click the button , the popup window will display. If I click twice, the popup window will disappear.

All the controls are changing together.

(Both my preview mode and running mode, the app works good.)

55.gif

 

 

 

If your problem still exists, please show me your settings about these controls and the button to make them visible.

Actually, I think your key problem is about order and fill. Please check these firstly.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helper II
Helper II

@v-yutliu-msft I have similar issue. My control works in studio and preview but it doesnt work once published. 

Super User
Super User

I have experienced this on complex screens with many controls. Oddly, repositioning the whole 'pop-up' (not the individual controls within it) resolved the issue.

It was very strange - like if there are too many controls layered over each other (with some marked as visible=false) PowerApps gets confused and doesn't render them properly. The control that was not rendering (a button) was the top-most element (z order). When moving the 'pop up' group either the whole button would appear or not appear, it was never a case that it was partially hidden. 

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (48,036)