cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Big_S
Post Patron
Post Patron

Could not execute workflow

Hi Guys,
Does anyone know what's happening? I didn't change anything and it was deployed already then this happens

here is my code and I have attached the screenshot of the error

Concurrent(
Set(_submittingRequest, true),

Set(_managerApprove, true));
Navigate(ManagerChangeRequestScreen, None);
Patch('[dbo].[Request]', LookUp('[dbo].[Request]', Id = GalleryRequests.Selected.Id), {ApprovalStatus: "Approved" , ApprovedDate: _leaveStart});
PowerAppsbutton_2.Run("Approved", "N/A", User().Email, TextInput1.Text);
Set(_submittingRequest, false)

 
2 ACCEPTED SOLUTIONS

Accepted Solutions
WarrenBelz
Super User
Super User

Hi @Big_S ,

Get rid of the Concurrent for a start. This is not what the function was designed for - it is for reading multiple tables from a data source concurrently to save time. If that does not fix it, happy to help further.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

View solution in original post

v-yutliu-msft
Community Support
Community Support

Hi @Big_S ,

Please try this:

delete the Flow connection from PowerApp, disabled the Flow then re enabled it.

then added it back into PowerApps again 

 

Someone has met the same problem, please refer this:

https://powerusers.microsoft.com/t5/Building-Power-Apps/Flow-Trigger-Error/td-p/302443

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
WarrenBelz
Super User
Super User

Hi @Big_S ,

Get rid of the Concurrent for a start. This is not what the function was designed for - it is for reading multiple tables from a data source concurrently to save time. If that does not fix it, happy to help further.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

View solution in original post

v-yutliu-msft
Community Support
Community Support

Hi @Big_S ,

Please try this:

delete the Flow connection from PowerApp, disabled the Flow then re enabled it.

then added it back into PowerApps again 

 

Someone has met the same problem, please refer this:

https://powerusers.microsoft.com/t5/Building-Power-Apps/Flow-Trigger-Error/td-p/302443

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi @warren Thank you so much for your suggestion i will try to execute this

Hi @v-yutliu-msft 

 

Thank you for this! I will surely execute your suggestion once again thank you

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,359)