cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Create Custom Connector - Timeout when saving from OpenAPI file

Hello All,

 

I am getting consistent timeouts when creating custom connectors for my API.

 

The swagger file is quite large, but well under the 1MB limit.

 

Here is the error message from the create new custom connector page:

 

The gateway did not receive a response from 'Microsoft.PowerApps' within the specified time period.

 

Please could the timeout be increased? Seems to be 60 seconds.  During these 60 seconds, the page says "Saving custom connector ..."

 

Thanks,

Matt

5 REPLIES 5
Highlighted
Community Support
Community Support

Re: Create Custom Connector - Timeout when saving from OpenAPI file

Hi MattDendle,

 

Could you try to use a small sized Swagger file on your side to see if you would get the same error?

 

Please also make sure your Network is working fine. Please test this on your side and back to me with the result.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate I
Advocate I

Re: Create Custom Connector - Timeout when saving from OpenAPI file

Hello Mabel,

 

Thank you for your reply.

 

Smaller sized swagger files work fine, but as I have many endpoints, this does not help me.

 

It appears as though the swagger file has already been sent to the server when this happens, and that the timeout error is a back end timeout rather than a timeout sending a file from my browser to the PowerApps infrastructure.

 

A network test from my office shows 82Mb down and 84 Mb up - Its not that.

 

I could not find any error references for you to look up I am afraid, but I am happy to supply you with the same Swagger file that I am using, via direct message.

 

Thanks,

Matt

Highlighted
Community Support
Community Support

Re: Create Custom Connector - Timeout when saving from OpenAPI file

Hi MattDendle,

 

If possible, please send the file to my Email Address: v-yamao@microsoft.com.

 

I will try to involve others to look into this issue.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate I
Advocate I

Re: Create Custom Connector - Timeout when saving from OpenAPI file

Thank you Mabel,

I have sent you the swagger file via email.

 

Thanks again,

Matt

Highlighted
Advocate I
Advocate I

Re: Create Custom Connector - Timeout when saving from OpenAPI file

Hello Mabel,

 

Did you have any luck in replicating the issue?

 

Kind Regards,

Matt Dendle

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (6,891)