cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
GiovanniMugno
Regular Visitor

Create new sharepoint item lists with a form from powerapps

I have a list in my sharepoint called "inventory", i need a form in powerapps that has only the function to ADD totally new list items to the sharepoint list, the problem is, when i put the the form in, and try to test the app, it says "there's no element to show", and when i try to give it an item, like linking it to a gallery that's connected with the exact same sharepoint list, and put in the item section of the form the function: "gallery1.selected", then it shows the info, but if i modify any of the data of the form, then it will not generate a new item, it will modify the selected item, and that's not what i want...

 

I need that the form shows the text entrys totally blanks, and then, when i saved the info that i typed in, with a button with the function: "submitform(form1)", it creates a totally new item in the sharepoint list; thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @GiovanniMugno ,

Based on the issue that you mentioned, I think there is something wrong with the DefaultMode property of the Edit form in your app.

Please consider set the DefaultMode property of the Edit form in your app to following:

FormMode.New

Set the OnSuccess property of the Edit form to following:

ResetForm(Form1)

4.JPG

 

Please take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
ericonline
Community Champion
Community Champion

Hi @GiovanniMugno ,
This is a common issue to encounter. The fix is to set the DefaultMode Property of your form to FormMode.New (instead of FormMode.Edit).Hope this helps.

image.png

v-xida-msft
Community Support
Community Support

Hi @GiovanniMugno ,

Based on the issue that you mentioned, I think there is something wrong with the DefaultMode property of the Edit form in your app.

Please consider set the DefaultMode property of the Edit form in your app to following:

FormMode.New

Set the OnSuccess property of the Edit form to following:

ResetForm(Form1)

4.JPG

 

Please take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,041)