cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Creating new Dynamics Lead with lookup fields generates error

I'm new to PowerApps so bear with me if this is considered common knowledge...

 

I'm trying to create a new lead record in Dynamics 365 which includes 3 custom lookup fields (. If I don't include the lookups on the forms it creates the new record without issues. When I add in the lookup fields back in it throws this error: "expected dataentityrecord for navigation column". I have searched high and low but haven't been able to find a solution.

 

 

4 REPLIES 4
v-micsh-msft
Community Support
Community Support

Would you please share more details about the lookup fields you are working with?

To work with Lookup fields in Dynamics 365, you may take a look at the following blog:

How to Connect with Dynamics 365 and use Lookup field of Dynamics CRM in PowerApps.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

I'm trying to create a basic lead intake form where I capture the First Name, Last Name, Email, Phone, Address1, City, State, Zip, Brand, Class, and Model of an item.

 

The lookup fields on the lead are tied to custom entities. There are three of them...

 

Brand

Class

Model

 

...For this particular app I would like to force the values for these three since they will always be the same. I can grab the id's easily enough but I can't seem to get it to allow me to write to these three fields. I tried using patch to just directly set the values but it throws a similar error, something to the effect of "the type of this argument does not match the expected type DataEntity." If I leave the threee lookup fields out of the equation everything works fine. If I add them in I get one of the aforementioned errors.

randybristol67
New Member

I am having the same issue when I use the Patch function to try to fill in my Lender lookup type field when creating a new record in my custom Payment entity. When I refer to the Lender field in my expression:

 

Patch(Payments, Defaults(Payments), { Lender: LoanGallery.Selected.Lender.Account})

 

I get the error:

 

The type of this argument 'Lender' does not match the expected type 'DataEntity'. Found type 'Guid.'

 

I am not sure how to proceed with updating my Lender lookup field using a Patch function.

Note that I am using the CDS data source.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (42,893)