cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
camel
Microsoft
Microsoft

Custom API - Data did not load correctly

Hi,

 

I am trying to use a Custom API that I developed, but it is not working. I have already configured OAuth 2, tested via PowerApps Custom API configuration screen and it is working.

 

But when I try to add the Data Source from my Web API I get the following error:

 

"The data did not load correctly. Try again."

 

When I click more, it shows:

 

"Resource not found

Session id: 815982a9-9b6e-f752-ae05-d61ce0126189"

 

Did someone experience this error?

 

Thanks in advance.

3 REPLIES 3
v-micsh-msft
Community Support
Community Support

Hi @camel,

 

Sometimes I will encounter similar error message (Resource not found or the Data did not load correctly. Try again ) when trying to load data from Dynamics 365, and after several attempts, the data would load.

Which make me think the connection should not be established successfully.

Would you please share some more information about the data source here? Are there any avaialble methods that we could do to monitor the query attempts from the data source side?

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

hi @v-micsh-msft,

 

I developed a Custom API to List and Remove Attachments from Sharepoint List's Items. The API is secured by an AAD

Application and the connector is using OAuth 2.0 to authenticate. I am not sure if this has to be with connection, because it has never worked for me. I can access normally from the web and also from the Custom API test part, but I cannot add the Custom API inside a PowerApps application.


@camel wrote:

hi @v-micsh-msft,

 

I developed a Custom API to List and Remove Attachments from Sharepoint List's Items. The API is secured by an AAD

Application and the connector is using OAuth 2.0 to authenticate. I am not sure if this has to be with connection, because it has never worked for me. I can access normally from the web and also from the Custom API test part, but I cannot add the Custom API inside a PowerApps application.


I have the same problem.

Is there already a solution?

 

Sander

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Carousel April Dunnam Updated 768x460.jpg

Urdu Hindi D365 Bootcamp

Dont miss our very own April Dunnam’s The Developer Guide to the Galaxy! Find out what the Power Platform has to offer for the traditional developer.

Top Solution Authors
Top Kudoed Authors
Users online (2,466)