cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jiwanovski
Advocate II
Advocate II

Custom API and Gallery

Hi everybody,

I have setup a custom connector. This connector have to different actions: One GET and one POST.

When I test the connector itself, it looks ok. For example I get this as response from GET:

{

"@odata.context": "ODataUrl",
"value": [
{
"@odata.etag": "W/\"JzM2O3VoTUFBQUo3LzBzQVZBQXdBREFBTUFBeEFESUFPQUFBQUFBQTc7Nzk3OTU4NDA7Jw==\"",
"ID": "afa4e204-3917-43d8-bd68-00e5d4513248",
"No": "000001",
"Name": "Mister Test"
},
{
"@odata.etag": "W/\"JzM2O3VoTUFBQUo3LzBzQVZBQXdBREFBTUFBd0FEQUFNZ0FBQUFBQTc7Nzk1NjI1NjA7Jw==\"",
"ID": "9f8e532f-bcfc-42a2-8760-01e7d63531dc",
"No": "000002",
"Name": "Miss Test"
}

}

 

Now I want to use this in a gallery. But actual I cannot add my custom connector as source of my gallery.

Can anyone help? Do I have to change anything in my custom connector?

 

When I try to trigger just my POST Action (it is also working when I test my custom connector itself) I receive an http 404 error. My custom connector has a basic authentication. 

11 REPLIES 11

@yukonn

We are using a Dynamics NAV 2018 database. And we can access this API from outside. The system is hosted an Azure and the ports are opened.

@v-xida-msft

I have checked the URL and the format is right.

 

Any other ideas?

RIght now I try to use Flow to access this custom connector...

Update:

When I use my custom connector with flow it works.

So I belive there is an error in power apps 😞

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Top Solution Authors
Top Kudoed Authors
Users online (4,719)