cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PowerAsh
Regular Visitor

Custom Connector Bug

Hi,

My dad (@Anonymous) and I found a bug when creating custom connectors for PowerApps with @booLauren.

If your custom connector name includes the word "SharePoint", when you try to connect to it in PowerApps, it gets very confused and tries to automatically connect to a SharePoint list, which then leads to an error. This issue is easily resolved once you create a new Connector, using the same swagger file, but don't include the word SharePoint (ie. in the screenshots below, the two connectors were created using the same swagger file. The only difference was the name. UploadPhototoSP worked fine but CreateSharePoint led to the following errors)

 

Ashlee Cat Happy

1 REPLY 1
v-micsh-msft
Community Support
Community Support

Thanks for reporting this.

 

This is a known issue and currently there is no workaorund that I can offer.

 

https://powerusers.microsoft.com/t5/General-Discussion/Data-Connection-Bug/m-p/62040#M25613

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (14,558)