cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
UncountedBrute
Helper I
Helper I

Custom Connector throwing Resource not found

I have written a set of API's in Asp.Net Core that surfaces the endpoints via swagger v2 (Open API). These endpoints require two api keys to authenticate. The first, retrieves the structure of the response. The second retrieves the data. In powerapps, I can create the custom connector via Import from Open API file (due to the swagger.json being locked down by authentication). And testing it in the test area works fine. When I add the connection to a powerapp, I get prompted for the first api key (powerapps doesn't seem to support multi auth). Once I enter the api key, an error is thrown of "Resource not found". As an example of a .Net Core route (not true to implementation due to privacy) please see the following:

 

 

///The format the response should be served as, e.g. xml, json. 
///The static key required to access the structure. 
///The dynamic key required to get data out. 
[Route("user/v1.0/{format}/{baseKey}/{apiKey}/{userName}")] 

 

 

We decided to test the same connectors in Power Automate (Flow) and this works correctly.

Any suggestions for what I may be missing would be appreciated.

0 REPLIES 0

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,066)