cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
marine_adz
Frequent Visitor

Custom Connector with multipart/form-data - missing header

I have set up a custom connector to an external system, successfully using get, post and delete using strings but am stuck on a couple of key functions where the Postman collection sets out multipart/form-data (even though one of the entries doesn't use a file).

 

When I test, it returns an error - looking at the request header, no content type is shown, only authentication - I've seen in other posts example request headers in the connector test screen that include it, so I'm fairly confident it can be done, just not sure how!

 

In the Swagger editor (swagger: '2.0') the following definition is set out:

 

 

/user_update_group/{user_id}:
  post:
    operationId: UpdateUserGroup
    summary: Update User Group
    description: Change the value of the user group assignment
    consumes: [multipart/form-data]
    parameters:
    - {name: user_id, default: '', in: path, type: string, required: true}
    - {name: group_name, in: formData, type: string, required: true, description: Group name}
    responses:
      default:
      description: default
      schema: {}

 

 

Any help gratefully received!

3 REPLIES 3
marcelofabiansc
Regular Visitor

Did you solve this? I'm on a similar situation.

Sadly not, we were lucky enough to be able to persuade the developers of the external system to modify their API to accept application/json.  Best of luck!

marcelofabiansc
Regular Visitor

ahh nice solution jeje thanks for answering ! 

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (2,691)