cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Custom PowerApps form

I have a custom PowerApps form that I been using for a while now, and suddenly the Edit button and New button stopped working. when I select an item on my sharepoint list and if I click Edit nothing happens, same with the New button. I haven't made any changes to the form and it was working properly, anyone else having this issue?

4 REPLIES 4
Highlighted
Resident Rockstar
Resident Rockstar

Re: Custom PowerApps form

Hi @edgar3tres,

No problem on my side, neither on an old customized form, nor on a form I customized and published just now.

Emmanuel

Highlighted
Helper I
Helper I

Re: Custom PowerApps form

I am having the same issue

I've republished, reverted to the sharepoint default and then republished, Checked for errors (none).

I've had to revert to the less than ideal sharepoint default to allow users to work.

It appears to be a relatively common issue going from the number of different posts over the last few days. Likely an issues with the latest update.

I will include this comment in all that are relevant in the hope that microsoft acknowledge and advise of fix.

Highlighted
Community Support
Community Support

Re: Custom PowerApps form

Hi @edgar3tres ,

 

I have seen multiple threads talking about the similar issue. Since I cannot reproduce your issue, is there any session ID that you could provide?

 

Other threads about the similar issue:

https://powerusers.microsoft.com/t5/Building-PowerApps-Formerly/Sharepoint-Custom-Form-not-open/m-p/...

https://powerusers.microsoft.com/t5/Building-PowerApps-Formerly/Sharepoint-Custom-forms-and-new-apps...

https://powerusers.microsoft.com/t5/Building-PowerApps-Formerly/New-amp-Edit-Button-not-working-in-M...

 

The issue should already been scalated to the relevant team.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Custom PowerApps form

Sorry Mona .. .I'm not sure how to determine the session ID but to expand on the issue i offer the following.

My custom form is supposed to launch from my Allitemsg.aspx page of my sharepoint list. But when I hover over the Item i wish to edit there is no recognition (ie Underlined Item... from memory it was before when the custom form worked). If i select an item in the sharepoint list the row highlights and the red tick appears beside the row. BUT if i click on the Edit  icon nothing happens, if i double click on the item nothing happens, if I deselect the row and click on new, nothing happens.. it is as if sharepoint doesnt recognise that the customised powerapp form is associated with the sharepoint list.

If I then open the form in powerapps and edit/run the form in powerapps then powerapps recognises / pulls the data from the sharepoint list so it appears powerapps if seeing the sharepoint list but not visa versa.

Screen shot of the area of the sharepoint list from which the custom form is supposed to launch is attached

 

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (9,205)