cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Custom Powerapps form for Sharepoint list intermittently displaying improperly

I am having an issue with a custom form that I created in Powerapps for a Sharepoint Online list that intermittently does not load properly when editing. The strange thing is, that it affects all users only sometimes, and can mostly be resolved by refreshing sometimes multiple times.

 

Causes that I have ruled out

Computer Configuration: I have been able to replicate this issue both on workstations within my domain, as well as personal devices.

Network Issues: I have been able to replicate this issue on multiple networks.

Browsers: This happens in IE, Edge, Firefox, Chrome, as well as Teams channels.

 

I set the custom form up with pretty much out of the box settings from Sharepoint Online/Powerapps. The only modifications that I made were deleting some unnecessary fields and changing the color scheme.

 

Has anybody else encountered this issue? And if so, were you able to find the cause/solution?

 

Below is a screenshot of the form in an error state:

Form errorForm error

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Custom Powerapps form for Sharepoint list intermittently displaying improperly

Hi @jtapscott ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please consider take a try to turn off the "Improved app rendering (finla validation)" option within Advanced settings of App settings of your app, then re-publish your app, and clear cache of your browser, sign in your SP List again, check if the issue is solved.

 

Also please consider take a try to re-store it to previous version, then re-publish it agian, check if the issue is fixed. More details about restoring app to previous version, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/restore-an-app

 

If the issue still exists, please consider take a try to remove the custom form from your SP List, then re-add a new one for it, check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
New Member

Re: Custom Powerapps form for Sharepoint list intermittently displaying improperly

Unfortunately, disabling Improved App Rendering did not solve the issue. I will be recreating the form today.

Highlighted
Regular Visitor

Re: Custom Powerapps form for Sharepoint list intermittently displaying improperly

I have the same issue.  It took me forever to create the form in the first place due to the number of fields.  Really hoping someone is aware of an alternate solution.

Highlighted
New Member

Re: Custom Powerapps form for Sharepoint list intermittently displaying improperly

I have tried doing every thing suggested, even recreating the PowerApp form from scratch and republishing to no avail. A workaround that I have offered my team is to use the Quick Edit option on the list when the form is misbehaving. Obviously this is not a solution, but it at least is still allowing us to use the lists.

 

One thought that I have is, my form has quite a few fields as well (16), perhaps network issues are causing a timeout when trying to load all of the fields, preventing the form from loading properly.

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (6,974)