cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
miller
New Member

Custom Property Disappearing from Component After Component Library Update

I published a new version of a component library, updated the component library in an app, and one of the custom properties disappeared even though it still shows in the component library. This happened to me once before and the property magically showed up again the next day, but it's going to be excessive if it takes a day to show up every time I publish a new version of the component library. Snips attached show the custom property in the updated library, the same component in the app before the component library was reviewed/updated, and the same component after the library was updated in the app. The custom property in question is the one called "On Select".

2 REPLIES 2
poweractivate
Super User
Super User

@millerTo troubleshoot:

 

1. Can you check if it still does this when the Component Property has hard coded value in it?

2. Can you check if it still does this when the Component Property has a name not containing a space?

3. Can you check if after adding a 3rd property then saving and publishing, if the first two properties show, but not the third newly added one?

 

Check if the above might lead to anything that might work for you as solution or workaround.

miller
New Member

@poweractivate

Checked the app today to see if the property fixed itself like it had last time, but it hadn't, so I tried a couple things:

 

  • I have several buttons in this library so I tried your first two suggestions on different buttons to compare. Published the new version of the component library, updated it in my app, and the property appeared.
  • Out of curiosity, I then went back to the library and put a button back to having no hard coding and with a space in the name. Published that version, and the property was still there... 🙁 So I can't say for certain that those two things were what made the difference.

I'll keep an eye on it incase it happens again and report back. Thanks for the trouble shooting tips. Wish I had kept one of my buttons as-is when I made the first troubleshooting attempt for a better comparison.

 

And I'm still getting up to speed with all of the lingo, so when you say "hard coded value" do you mean making sure the property's field isn't blank in the function bar at the top of the screen?

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (1,730)