cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Custom Property in PowerApps

I created a component in PowerApps (i name it as "Separator") to use it as header for certain group of fields on the form.

Component has a label which shows the text which is passed via custom input property called "SectionTitle"

Now label's text property is set to Separator.SectionTitle.

 

Now when i initially set the section title property, it works fine. But after some time it becomes blank.

SectionHeaderIssue.png

 

Anybody facing similar issue ? how can i resolved this issue.

 

Thanks in advance

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Anonymous ,

You mean you insert component inside a form?

Actually this is component's limitation:

Nesting: components cannot be inserted into galleries, forms, and data cards today. Likewise, forms and data-grids cannot be embedded into components.

 

Please do not insert component inside a form, which will lead to some problems.

 

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
ShantanuP
Power Apps
Power Apps

How are you setting SectionTitle property? Does it go blank without you setting it again? Can you provide little more details about how you are setting it up?

 

v-yutliu-msft
Community Support
Community Support

Hi @Anonymous ,

Do you mean that your label becomes blank after some time?

Have you made any change on your SectionTitle property?

I've made a similar test but not met the same problem like your description.

Here's my test , please check whether you've made any mistake:

1)create component , named Separator

insert a custom property, set like this:

565.PNG

 insert a label inside the component, set the label's Text:

Separator.SectionTitle

 

2)inside the app, insert this component

set Separator_1's SectionTitle:

"aaa"

 

Then the text will display correctly and it will not disappear after some time.

566.PNG

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

@ShantanuP  @v-yutliu-msft 

I created it as Custom Input Property.

The value is already set but it is not visible not sure why. I already tried to bring the label to front / forward but still not results.

If i change anything to the existing text then it appears in designer but still does not appear on published app.

As you can see below. Property has the value but the section is actually blank.

 

SectionHeaderIssue.png

Hi @Anonymous ,

You mean you insert component inside a form?

Actually this is component's limitation:

Nesting: components cannot be inserted into galleries, forms, and data cards today. Likewise, forms and data-grids cannot be embedded into components.

 

Please do not insert component inside a form, which will lead to some problems.

 

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (1,846)