cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JamesM
Helper V
Helper V

Custom connector changes not reflected in PowerApps App

I find that after creating a new method in my custom connector, it doesn't show up for calling/invocation in my PowerApps app. Sometimes not for a whole day? Then bam, it suddenly appears. What gives? I was removing and re-adding my data source (for the custom connector) to force it to pick up changes, but even that doesn't seem to work every time. Is there some refresh I'm missing? 

11 REPLIES 11
Mglat
Advocate IV
Advocate IV

Looks there is a background deployment in place. My experience with other types of changes and background deployments it that during the weekend this can take a lot longer then during workdays. 

To refresh the changes instantly I found a workaround. Exit the 'edit mode' of the connector and download the definition to a file. And then directly import it again (the three dot symbol) as 'Update from OpenAPI file'

2021-06-20_14-26-37.png

Harold_Anderson
Helper II
Helper II

@Mglat Thanks, that worked.

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (3,365)