cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Custom connector for Graph API

I have created a custom connector using Graph API to display user profile information and groups. The test in custom connector fetches all  attribute values of a user email address.

But when using the connection in powerapps form the API does not fetch any attribute value for a given emailid. I could see the collection created with column names, but there is no value fetch or any error message displayed

 

ClearCollect(myProfileInfo,Graph.getUser(User().Email).value)

 

I have tested the graph API url in postman and graphexplorer the profile info of the user is fetched.

 

Could you please advise

1 REPLY 1
Community Support
Community Support

Please take a try to use the custom connector Test part to check if it could return the proper Email ID:

27.PNG

 

If it can't be done, then please share your Open API file.

Further, make sure the App registered for Graph API is still available to use.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (5,686)