cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Custom connector receives information in wrong format

Hello, I am trying to create a custom connector that ties to Azure API Management.

The custom connector test response has the following format:

image.png

 

Then I created a collection in order to store the values, and this was the result:

image.png

 

Why aren't the values mapped accordingly to the custom connector test?

 

Thanks everyone.

2 REPLIES 2
Highlighted
Frequent Visitor

Re: Custom connector receives information in wrong format

Solution was found. When creating the custom connector it is mandatory that the shape of Response is defined with a body in JSON otherwise the fields won't be recognized.

Highlighted
Community Support
Community Support

Re: Custom connector receives information in wrong format

Hi,

 

It looks like you were able to figure out your issue here on your own. I just wanted to follow up with some additional information if you would like to learn more. Feel free to take a look.

 

https://docs.microsoft.com/en-us/connectors/custom-connectors/define-blank

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (12,072)