cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
randomsky
Helper I
Helper I

Custom connector returning binary output

I've created a custom connector to get data from a calendar feed. The data it returns is in the format:

 

 

BEGIN:VCALENDAR
CALSCALE:GREGORIAN
VERSION:2.0
X-WR-CALNAME: TestApp
PRODID:-//Company//TestApp//EN
METHOD:PUBLISH
BEGIN:VEVENT
DTSTART;VALUE=DATE:20221101
DTEND;VALUE=DATE:20221102
SUMMARY:Start Test 19799
URL;VALUE=URI:https://app.my.com/job/jobview.aspx?id=53932947
DESCRIPTION:test\n\nhttps://app.my.com/job/jobview.aspx?id=53932947
UID:JS53932947
SEQUENCE:0
END:VEVENT
BEGIN:VEVENT
DTSTART;VALUE=DATE:20221105
DTEND;VALUE=DATE:20221106
SUMMARY:Complete Test 19799
URL;VALUE=URI:https://app.my.com/job/jobview.aspx?id=53932947
DESCRIPTION:test\n\nhttps://app.my.com/job/jobview.aspx?id=53932947
UID:JE53932947
SEQUENCE:0
END:VEVENT
BEGIN:VEVENT
DTSTART;VALUE=DATE:20221101
DTEND;VALUE=DATE:20221102
SUMMARY:Test 19800
URL;VALUE=URI:https://app.my.com/job/jobview.aspx?id=53932952
DESCRIPTION:test 2\n\nhttps://app.my.com/job/jobview.aspx?id=53932952
UID:J53932952
SEQUENCE:0
END:VEVENT
BEGIN:VEVENT
DTSTART;VALUE=DATE:20221115
DTEND;VALUE=DATE:20221116
SUMMARY:Start Test 19801
URL;VALUE=URI:https://app.my.com/job/jobview.aspx?id=53932958
DESCRIPTION:test 3\n\nhttps://app.my.com/job/jobview.aspx?id=53932958
UID:JS53932958
SEQUENCE:0
END:VEVENT
BEGIN:VEVENT
DTSTART;VALUE=DATE:20221117
DTEND;VALUE=DATE:20221118
SUMMARY:Complete Test 19801
URL;VALUE=URI:https://app.my.com/job/jobview.aspx?id=53932958
DESCRIPTION:test 3\n\nhttps://app.my.com/job/jobview.aspx?id=53932958
UID:JE53932958
SEQUENCE:0
END:VEVENT
END:VCALENDAR

 

When I test the response from the custom connector it returns the data correctly with a 200 response. However when I try calling the connector from within the PowerApp it returns a true:

randomsky_0-1638243760579.png

Not sure what I'm missing. I've tried opening the browser with the Power App in incognito mode but that didn't help. Any guidance appreciated. Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
v-xiaochen-msft
Community Support
Community Support

Hi @randomsky ,

 

Usually this situation is that you use the wrong response body.

Since powerapps is static, the response body need to match the body. Please check it .

If your body output is invalid in response body, I suggest you use http action in flow.

 

Best Regards,

Wearsky

View solution in original post

4 REPLIES 4

@randomsky 

Probably the usage from the formula is not correct.

 

Try reviewing here to make sure:

https://docs.microsoft.com/en-us/connectors/custom-connectors/use-custom-connector-powerapps#add-for...

 

Next, I recommend to try with returning only the data without putting it into a collection first, and see if it works.

 

Such as just using something like:

 

 

YourConnector.YourAction(YourInput_OnlyIfNeeded)

 

 

Only after checking the above returns data into the PowerApp as just text first, then try it in Collection after that.

 

Check if it helps.

v-xiaochen-msft
Community Support
Community Support

Hi @randomsky ,

 

Usually this situation is that you use the wrong response body.

Since powerapps is static, the response body need to match the body. Please check it .

If your body output is invalid in response body, I suggest you use http action in flow.

 

Best Regards,

Wearsky

Hi @poweractivate ,

 

I tried that but still get a boolean:

randomsky_0-1638695367783.png

 

Thanks @v-xiaochen-msft , yes, I think using a flow may work better for this situation.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (2,787)