cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PowerExplorer
Helper I
Helper I

Customized Sharepoint Form shows previous data on View/New/Edit

Powerfolks Please I need help  ,with the issue explained here , I'm having same issue, My SP list customized form is very simple less than 10 columns and no much validation/code.  And i only have one form control/SharePointForm1. So, whenever any form is opened(View,new,edit) it loads the previous data/entry for 1/2 sec before loading the right data . Unless I refresh in between all clicks.

 

Let's say If I refresh before clicking another item it shows blank form before loading the item , which is better than showing previous data.

It confuse users and  you can't tell hundreds of users to refresh each time they click item to view or create or edit. It just falls under an issue that PApps isn't refreshing properly  / caching... 

I've tried 

1. 

Refresh('SP list'); ResetForm(SharePointForm1);EditForm(SharePointForm1)
Refresh('SP list');ResetForm(SharePointForm1);NewForm(SharePointForm1)
Refresh('SP list');ResetForm(SharePointForm1); ViewForm(SharePointForm1)

 

And reverse order,  1st resetform then refreshForm, 

ResetForm(SharePointForm1); Refresh('SP list'); ViewForm(SharePointForm1)

 

2. Onsuccess : Refresh('SP list'); ResetForm(SharePointForm1);RequestHide()

 

Nothing solved. 

 

@v-siky-msft  @RandyHayes  @WarrenBelz    -  I've tried many of your suggestions. It didn't work. Any further soln I should try? Thank you in advance. 

 

3 REPLIES 3
WarrenBelz
Super User
Super User

@PowerExplorer ,

I have read a number of responses on the thread you referenced.

Quite simply, this is (although not acceptable to you) fairly normal behavior my users experience as well and are simply told to ignore. I have several forms that display a heap of information including a gallery, a form selected from it and then another gallery referencing the form. A second or two for it all to resolve when another item is chosen fro the gallery is quite normal. If it really bothers you, put a timed "spinner" on the screen with an opaque background for a couple of seconds.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

RandyHayes
Super User
Super User

@PowerExplorer 

My only suggestion in addition to @WarrenBelz comments would be to set your default form mode to New and before you do a RequestHide() do a ResetForm.  This should put the form in a blank state so that the next time it appears it will be blank until the record loads.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!
PowerExplorer
Helper I
Helper I

Thank you very much @WarrenBelz @RandyHayes . I'll give it a shot your suggestion.

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (1,933)