cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
AveDog08
Level: Powered On

Data Gateway SQL New Table Fields Not DIsplaying

I have an on-premisis SQL server datasource connected via gateway. I added a new field to a table, and I suspect there is some sort of syncing period, but it's been a good 30 min with no sign of any changes I made to the table structure. Is there something I'm missing?

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Data Gateway SQL New Table Fields Not DIsplaying

Hi @AveDog08 

Have you refreshed your SQL data source via the View > Datasources menu item? There's a refresh menu item in the (...) icon against the data source. Clicking this should refresh the data schema.

View solution in original post

3 REPLIES 3
AveDog08
Level: Powered On

Re: Data Gateway SQL New Table Fields Not DIsplaying

Same result when adding views. It seems to know right away when I delete a view, but new views and tables are not shown

Super User
Super User

Re: Data Gateway SQL New Table Fields Not DIsplaying

Hi @AveDog08 

Have you refreshed your SQL data source via the View > Datasources menu item? There's a refresh menu item in the (...) icon against the data source. Clicking this should refresh the data schema.

View solution in original post

AveDog08
Level: Powered On

Re: Data Gateway SQL New Table Fields Not DIsplaying

Yes, Multiple times. It seems to know when I delete views but not when I alter or create them. I tried 2 HRs later and everything finally updated.

Helpful resources

Announcements
thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors
Users online (5,712)