cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Data Gateway SQL New Table Fields Not DIsplaying

I have an on-premisis SQL server datasource connected via gateway. I added a new field to a table, and I suspect there is some sort of syncing period, but it's been a good 30 min with no sign of any changes I made to the table structure. Is there something I'm missing?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: Data Gateway SQL New Table Fields Not DIsplaying

Hi @AveDog08 

Have you refreshed your SQL data source via the View > Datasources menu item? There's a refresh menu item in the (...) icon against the data source. Clicking this should refresh the data schema.

View solution in original post

5 REPLIES 5
Highlighted
Helper II
Helper II

Re: Data Gateway SQL New Table Fields Not DIsplaying

Same result when adding views. It seems to know right away when I delete a view, but new views and tables are not shown

Highlighted
Super User
Super User

Re: Data Gateway SQL New Table Fields Not DIsplaying

Hi @AveDog08 

Have you refreshed your SQL data source via the View > Datasources menu item? There's a refresh menu item in the (...) icon against the data source. Clicking this should refresh the data schema.

View solution in original post

Highlighted
Helper II
Helper II

Re: Data Gateway SQL New Table Fields Not DIsplaying

Yes, Multiple times. It seems to know when I delete views but not when I alter or create them. I tried 2 HRs later and everything finally updated.

Highlighted
Frequent Visitor

Re: Data Gateway SQL New Table Fields Not DIsplaying

@timl  - The refresh Data Source method has no effect for new SQL Server tables and views (and stored procedures in flow) in my experience. You have to wait quite some time before they appear. Why is this? And why is this thread marked as Solved when it clearly is not?

If you have an existing Data Source then yes, the refresh may reveal new columns etc. but this thread is about new Data Sources (from existing Connections) not existing Data Sources.

Highlighted
Super User
Super User

Re: Data Gateway SQL New Table Fields Not DIsplaying

@andrew121

I'm not sure why there is a delay before SQL schema changes appear.

When I began using PowerApps and for some time after, they never used to be this delay.

One thing that might help is to stop and start the gateway service. Sometimes that forces schema changes to show up.

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,558)