cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Blurred
Regular Visitor

Data Source not connecting to "choice" settings in a Sharepoint list

I have created an app from scratch. I have created two forms using two different Sharepoint lists as the data source. Both lists have "choice" columns. The two Sharepoint lists are very similar. One form looks great. The second form shows errors for all of the "choice" fields even thought the "form" data source is correct. When I look at the advanced options of the data card is says "No data" beside the data field on the right hand side of the screen. How do I get these data cards to connect to the data source?

1 ACCEPTED SOLUTION

Accepted Solutions

Hello, I have been off this task for a while. Just getting back to it now. I did try all the suggestions. It did not work. After taking a break and coming back to it months later the errors have cleared. Not sure if there was a gitch or an update but all fields are working now. Thanks for all the help trying to get it to work.

View solution in original post

5 REPLIES 5
v-monli-msft
Community Support
Community Support

Hi @Blurred,

 

First of all, select View tab > Data Sources tab > then Refresh the connector on the right side.

Capture.JPG

 

Then select the Form control, make sure its data source is the right connector. And uncheck the checkbox of the Choice column data card, and check it back to add it back again. See if this could solve the issue.

Capture.JPG

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for the suggestions. I tried them and I am havign the same issue.

Hi @Blurred

 

Firstly , I think you should make sure your arguments and data setting is valible in SP list.

The Choice type has data and its tye is choice. And then if it not show again you should check the item have data or not, you can set the card's item:Choices('table name in SP list'.Column name in SP list).

I am not sure whether this can solve your issue. But hoep this can be helpful for finding the solution to your issue.

Thanks a lot.

sp_choice.png20181214choice1.png20181214choice2.png

 

Anonymous
Not applicable

Thanks for your help with this post @v-monli-msft and @xyzzyx666.

 

@Blurred - can you review the information provided and advise if it's solve your problem?

 

@Anonymous

Hello, I have been off this task for a while. Just getting back to it now. I did try all the suggestions. It did not work. After taking a break and coming back to it months later the errors have cleared. Not sure if there was a gitch or an update but all fields are working now. Thanks for all the help trying to get it to work.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (1,725)