cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Data Table not displaying data

It was working just fine about 2 days ago but now my data tables do not display anything. I have a home screen that has a gallery then based on that gallery id I filter my data table on the next screen. I've tried everything but no luck.

 

Any Ideas? Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Figured it out! For some reason my function/syntax stopped working as it was working fine before. So to get it to display I used the following:

 

SortByColumns(Filter('[dbo].[power_deal_vendor]', Text(deal_id) = DataCardValue5_1.Text), "id", Descending)

 

 

Instead of converting the right hand side with Value(DataCardValue5_1.Text) I did it on the left side instead even though it gives me a warning sign.

View solution in original post

9 REPLIES 9
Highlighted
Anonymous
Not applicable

Hello,

Have you tried simply removing the data table and re-adding it?

Otherwise providing a screenshot and the function/syntax you use might help resolve this for you.

Highlighted
Advocate I
Advocate I

I've attached an image of what my table looks like, empty and here is  my function/syntax:

 

SortByColumns(Filter('[dbo].[power_deal_vendor]', deal_id = Value(DataCardValue5_1.Text)), "id", Descending)

Highlighted
Advocate I
Advocate I

I've tried re-adding the table as suggested but nothing and also it displays data on the edit environment but not once published.

Highlighted

Hey,

 

Have you tried testing if you're getting data without filtering just to check if you're receiving any data at all?

Highlighted

Did not try this but when not filtering just regular o data source it works.

Highlighted
Advocate I
Advocate I

Figured it out! For some reason my function/syntax stopped working as it was working fine before. So to get it to display I used the following:

 

SortByColumns(Filter('[dbo].[power_deal_vendor]', Text(deal_id) = DataCardValue5_1.Text), "id", Descending)

 

 

Instead of converting the right hand side with Value(DataCardValue5_1.Text) I did it on the left side instead even though it gives me a warning sign.

View solution in original post

Highlighted

Hi,

I guess you are getting the warning because of the delegation. You are issuing a function on the data source itself, this could led you to bad performance later on.

 

Is the "DataCardValue5_1.Text" a number? try to fix it on the PowerApps side to avoid issues along the way.

Highlighted

Yes, it is a number and yes I got the warning sign but its the only way I could make it work. It wont display doing it the correct way which was:

 

id = Value(DataCardValue.Text)

 

which was working but suddenly stopped working and I do not know why.

Highlighted

It should work that way but it might be a conversion issue.

 

Have you tried veryfing the result of Value(DataCardValue.Text) in a variable?

UpdateContext({test:Value(DataCardValue.Text)}) 

 

And then check the variable though View / Variables.

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (2,578)