cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
smartin
Helper II
Helper II

Data Table not showing the right data!! Help!

Hey guys

 

Strangest thing is going on with my Data Table in my app. 

I have two columns, one called Employee ID and the other called Specialist Name. 

 

For some weird reason, my employee ID data is showing up in both columns even though the code on both columns in separate.

Code on each column in ThisItem.Employee_ID and ThisItem.Specialist_Name. 

 

In the first 3 seconds...you can see the name of the person show up, but then it switches to the employee #. I'm at a loss. 

 

smartin_0-1612272811253.png

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
JR-BejeweledOne
Super User
Super User

The data looks right in the SharePoint list?   If so, here is where I would start.  I would look in all the properties of the Specialist_Name column and make sure I didn't accidentally type or copy a formula somewhere it isn't supposed to be.  

 

If you data looks correct everywhere else and you don't find any errant formulas, then delete the column from your table, save the app and then re-add it to see if that will resolve the issue.



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

View solution in original post

5 REPLIES 5
JR-BejeweledOne
Super User
Super User

What is your data source for the table?



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.
smartin
Helper II
Helper II

My bad. I should have shared that too. I'm connected to a sharepoint list. 

JR-BejeweledOne
Super User
Super User

In your data table properties card on the right side of your screen, when you click on 'Edit fields' does it show your columns correctly?

 



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.
smartin
Helper II
Helper II

Yeah, they do. 

 

smartin_0-1612276161527.png

 

JR-BejeweledOne
Super User
Super User

The data looks right in the SharePoint list?   If so, here is where I would start.  I would look in all the properties of the Specialist_Name column and make sure I didn't accidentally type or copy a formula somewhere it isn't supposed to be.  

 

If you data looks correct everywhere else and you don't find any errant formulas, then delete the column from your table, save the app and then re-add it to see if that will resolve the issue.



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (1,265)