cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MichaelMelo
Frequent Visitor

Data Table taking 20 seconds to load

Hi All,

I have a data table connected to SQL server in Azure getting about 500 rows and with 55 columns.

 

This always worked nice but, after add two more columns in the view, the screen got very very slow and the table is taking 20" to open.

Any one know what can be? I have a different version of this app without modifications in the data table, getting the same quantity of the rows and working very fast.

1 ACCEPTED SOLUTION

Accepted Solutions

The Microsoft have discovered a problem in the data table and will fix in the update this weekend.

View solution in original post

11 REPLIES 11
eka24
Super User
Super User

For a Datatable, have you considered a collection Onvisible of the screen;

ClearCollect(MyTable, Datasource)

 

Then use the Collection on the Items property of the Datatable instead.

 

If you still want to Use the direct source, I suggest you remove the table connection and reconnect it again.

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Thanks for your answer but, I'm doing exactly like that.

Populating the collections in OnVisible and using the collection to populate the data table.

Ok in that case remove the table from Powerapps and reconnect same table again and restart the App

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Already did it and also create a new data table.

Few more clarification

1.How many second did it took

2.What is the datatype for the 2 new columns

 3.How many seconds does it take when you are to use a Gallery instead of Datatable

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

1.How many second did it took
25 seconds.

2.What is the datatype for the 2 new columns
Text


3.How many seconds does it take when you are to use a Gallery instead of Datatable
Testing with Gallery i used only two columns and open in 2 seconds.

MichaelMelo
Frequent Visitor

Guys,

Anyone know why this is happening? The same query but when we check in the monitor:

Request from DEV APP 
"request": {
"url": "https://europe-001.azure-apim.net/apim/sql/d9378941429e49189d47db658ab12fe3/v2/datasets/euwe01uatsqlserver01.database.windows.net,RecTool_UAT/tables/%255Bdbo%255D.%255Bdim_REC_Data%255D/items?%24filter=EntityName+eq+%27NRSA%27&%24top=500",
      "method": "GET", …
    },
Request from MAIN APP:

"request": {
      "url": "https://europe-001.azure-apim.net/apim/sql/d9378941429e49189d47db658ab12fe3/v2/datasets/euwe01uatsqlserver01.database.windows.net,RecTool_UAT/tables/%255Bdbo%255D.%255Bdim_REC_Data%255D/items?%24filter=EntityName+eq+%27NRSA%27&%24select=ID%2CEntityName%2CTrade_x0020_ID%2CPosition%2CCounterparty_x0020_Name%2CCommodityCode%2CCreationName%2CTradingSystem%2CTrade_x0020_Date%2CBroker_x0020_Name%2CCommodity_x002f__x0020_Origin%2CQuantity%2CQuantity_x0020_units%2CPrice%2CPrice_x0020_Currency%2CPrice_x0020_Unit%2CParity_x0020_1%2CParity_x0020_2%2CQuality_x002f_Specs%2CContract_x0020_Form%2CDelivery_x0020_From%2CDelivery_x0020_To%2CPayment_x0020_Terms1%2CPayment_x0020_Terms2%2CPayment_x0020_Currency%2CFeeMethod%2CPositionClass%2CCompany%2CProfitCenter%2CTrader%2CProductType%2CTradeType%2CCreationDate%2CRevisionDate%2CRevisionName%2CColumnModified%2COrigValue%2CModValue%2CNew_x0020_Trade_x0020__x002d__x0020_Trading_x0020_BO_x0020_Audit_x0020_Trial%2CAmended_x0020_Trade_x0020_Trading_x0020_BO_x0020_Audit_x0020_Trial%2CConfDate%2CTBO_x0020_Resolution_x0020_Date%2CDate_x0020_Diff_x0020_Creation_x0020_To_x0020_Trade%2CDate_x0020_Diff_x0020_Conf_x0020_To_x0020_Trade%2CDate_x0020_Diff_x0020_Resolution_x0020_To_x0020_Trade%2CDesk%2CFinalizedDate%2CAgeing%2CPrice_x0020_Index%2CTime_x0020_Period%2CContractualChange%2CTrade_x0020_Confirmation_x0020_Status%2CTrade_x0020_Reconciliation_x0020_Status%2CConfirmation_x0020_Source%2COriginOptionality%2CIntercompanyCheck%2CResTradeType%2CTBO_x0020_Excellence%2CTradeStatus%2CExecution_x0020_Check%2COpen_x002f_Close_x0020_STATUS%2CTradeDumpFileName%2CCofco_x0020_Direction&%24top=500",
      "method": "GET",
…
    },

Its like the MAIN APP is doing a select with all columns and the DEV App is using the only one filter necessary EntityName. Do you know what can cause it?

Clear(AllAssignedTrades);
Set(
    userId,
    LookUp(
        '[dbo].[dim_User]',
        EmailID = User.Text
    ).UserID
);
ClearCollect(
    EntityFileName,
    ForAll(
        Filter(
            '[dbo].[dim_User_Entity]',
            User_ID = userId
        ),
        LookUp(
            '[dbo].[dim_Entity_Name]',
            Enity_Name_ID = Entity_ID,
            Entity_Name
        )
    )
);
ForAll(
    Split(
        Concat(
            EntityFileName,
            Value & ","
        ),
        ","
    ),
    Collect(
        AllAssignedTrades,
        Filter(
            '[dbo].[dim_REC_Data]',
            EntityName = Result
        )
    )
);
ClearCollect(
    AllMyTrades,
    AllAssignedTrades
)

 

The Microsoft have discovered a problem in the data table and will fix in the update this weekend.

It hasn't been fixed yet - at least not on our tenant

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (2,178)