cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
michowl
Microsoft
Microsoft

Data cards change order when viewed on different platforms: mobile, web, preview

 

I'm having an issue in which my data cards are appearing in different orders on different platforms. I've tried 3 methods and none provide a consistent ordering across iOS, web and web editor preview mode.

 

I have 2 forms that show/hide data cards depending on toggled context variables controlled by other fields.

 

For the first form, I used the method described in this post--padding the Y values of each card:

https://powerusers.microsoft.com/t5/PowerApps-Forum/How-to-stop-datacards-from-changing-their-order/...

 

This works for form 1 and still works for it, across all platforms.

 

For the second form, I wanted to try something a little more elegant, so I use something along the lines of:

DataCard2.Y=DataCard1.Y+DataCard1.Height

DataCard3.Y=DataCard2.Y+DataCard2.Height

 

this worked for a long time until this week. I opened my app on Monday, and the toggled datacards, when visible, show up in an overlapping stack. I added a textbox to view their Height & Y values, and they all have the same Y, and it does not change when toggled! This behavior was only present in the browser play app mode. Mobile and editor preview continued to display correctly.

 

So I changed the Y values to be based on the last non-toggled datacard's Y:

DC2.Y=DC1.Y+DC1.Height

DC3.Y=DC1.Y+DC1.Height+DC2.Height...

 

This worked in preview and browser, but is broken in mobile > one card is reordering itself.

 

So I tried the fixed values method that I used on my first form. This didn't work at all for form 2, though form 1 is still performing correctly. Form fields are all rearranged in form 2 in all platforms.

 

I'm not sure what other recourse I have. Option 1 (y based on y+ht of data card above) should be the optimal route, and could be fixed by exposing z-values (checking in dev mode on Chrome, the datacards all have different z positions, which is why they overlap).

Option 2 should be working without issue. That's gotta be a bug.

Option 3 is also a bug, and is the issue addressed in OP.

2 REPLIES 2
Anonymous
Not applicable

I have faced the same problem. By default controls for any datacard are locked. Try to unlock the control and then move the card to desired location. It worked for me. Please give it a try.

The data cards are all unlocked, as I've done extensive customization of them all.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (75,855)