cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sfishe
Helper II
Helper II

Data connection timeouts without error or warning

I get seemingly random timeout issues with my app that I can't figure out.

 

The data sources are SharePoint Lists, and the app is accessed via the web (Dynamics 365) using Mac Chrome (latest beta stream build).

 

The app is typically 'open' (i.e. sitting on a gallery or similar screen) for 5-6 hours. During this time, multiple NewForm or EditForm screens may each be open for up to an hour. At some point, at least after an hour or so of usage, PowerApps will fail to save a form - clicking the SaveForm button will just result in the "loading data" animation at the top constantly repeating (at least for 15mins...). Also, trying to open a dropbox list box on the form that loads options from a SharePoint List will fail (the items never populate). The only way to resolve this is to close the tab and load the app again - this works fine and immediately. So it doesn't appear to be a simple connectivity issue.

 

At no stage do I get a session timeout warning (I have seen these before). It doesn't appear related to that kind of timeout. Also the timing of when it occurs appears variable. For example, it could happen half an hour after just happening and having to restart the app.

 

Any thoughts?

6 REPLIES 6
v-monli-msft
Community Support
Community Support

Hi @sfishe,

 

Is this happening to all the apps? Please try to create a new one to have a test. Also, try to open this app from the PowerApps app on the mac.

 

If the issue could be reproduced, please tell us the version of your ios and chrome. Also your session id.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

There's not a version of PowerApps studio for OS X is there? I'm using that, not iOS.

 

I'll try with a new app, using the same data source in a simpler way I guess.

 

Also, how do I get the session ID?

Hi Mona,

 

Any way to look into this further?

*bump*

 

This is still a significant problem for me - I have to reload the PowerApp at least 3-4 times across 5 hours of use.

 

any ideas? How can I troubleshoot it?

Hi @sfishe, are you still having this issue? We recently released some fixes for something similar to what you describe, and I wanted to check whether this is the case.

Anonymous
Not applicable

Hi @AlanC, (and @anees)

I can confirm that we are still having what looks like the same issue:

https://powerusers.microsoft.com/t5/General-Discussion/Intermittently-get-An-unknown-error-occurred-...

 

Can you please provide me with the information about the known issues, and what fixes have been applied when?

 

Thanks

Anne

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (40,779)