cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Data not always loading into forms

My users are having an intermittent problem with my app. The data is in a SQL database that I'm connecting to with an on-premise data gateway. I have a gallery that loads a bunch of items. When you select the item it brings you to a form where details are displayed and can be edited. The problem is that sometimes those details don't load. If a user exits PowerApps and then reloads the app, the data is there. I have no idea how to troubleshoot this.

5 REPLIES 5
Highlighted
Resolver III
Resolver III

Re: Data not always loading into forms

I find the same, with forms sometimes not correctly populating the dropdown defaults. i also find that sometimes Refresh(source) doesnt work, and needs to be done twice.

Highlighted
Community Support
Community Support

Re: Data not always loading into forms

Hi @AAK1,

Could you please share a bit more about your issue?

I have made a test on my side, and don't have the issue that you mentioned.

Please check if the DataSource property of the Form in your app is set to same data source as that in your Gallery. Please make sure the Item property of the Form to following:

BrowseGallery1.Selected

In addition, please also consider take a try to disable/turn off the "Explicit column selection" option and "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-publish your app, check if the issue is solved.

 

If the issue still exists, please consider take a try to re-create a new app based on your SQL table, then check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Data not always loading into forms

I've double checked all the things you mentioned and they are correct. I went ahead and also turned off the two features in advanced settings and will see how that goes. The issue is that this is a very intermittent problem. Approximately 80% of the time, everything works as expected. I'm going to ask users to test, but I don't know that I will get a rapid response.

Highlighted
Community Support
Community Support

Re: Data not always loading into forms

Hi @AAK1,

Have you solved your problem?

If you have solved your problem, please go head to click "Accept as Solution" to identify this thread has been solved.

 

If the issue still exists, please take a try to consider submit an assisted support ticket through the following link:
https://powerapps.microsoft.com/en-us/support/pro/

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Data not always loading into forms

Unfortunately, I have not solved this. I'll try putting in a ticket.

Helpful resources

Announcements
Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,465)