cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Re: Data source may be invalid

I'm having the exact same issue when submitting forms to the CDS. The submit button suddenly has an error message "The requested operation is invalid. Server response: A value must be provided for this item" which comes and goes. When I click the submit button I get the red header error "Your data source may be invalid." Oh, and the Edit forms do not load consistently, they're sometimes blank for no reason. This all started on Monday--the app was previously working perfectly, and I had made no changes to it. 

Highlighted
Regular Visitor

Re: Data source may be invalid

I am currently suffering from the same issue with an almost idenical app set up. I recently changed my data source from a excel spreadsheet in OneDrive to a Sharepoint list. The list is currently gives "Everyone except external users" edit permission, however some people are able to use the app normally and some recieve the error messages. I have tried reconnecting the data connections. 

 

Session ID: b51d16ca-b6b3-4a99-b162-99af85c0217b
PowerApps 3.18075.22

 

Please help!

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Data source may be invalid

Did you follow the advice to add the refresh(SharePoint list) in the SharePoint Integration Object?

 

See my blog here

 

https://skylitesystems.com/blogs

 

 

Highlighted
Regular Visitor

Re: Data source may be invalid

Thank you for responding!

 

Where can I find the SharePoint Integration-->On Edit?

 

I have one gallery displaying items from the list, one new form adn one edit form.

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Data source may be invalid

Look in the lefthand column when you customize the form ...

 

If this is NOT a sharepoint list with an attached embedded SharePoint form then follow the advice given earlier in this thread 

 

https://powerusers.microsoft.com/t5/General-Discussion/Server-Response-ETAG-mismatch-clientRequestId...

 

Focus on the post that starts with "Todays the day.... on page 7"

 

 

 

Highlighted
Regular Visitor

Re: Data source may be invalid

I added the following lines to the OnSelect section of the add new button and edit button in my gallery adn check mark on both my new form and edit form. I still recieve the same errors.

 

OnSelect (Gallery-Add new item)

Navigate(TimeSubmission, ScreenTransition.Fade)

 

OnSelect (Gallery-Edit Item)

Navigate(EditTimeSubmission,ScreenTransition.Fade)

 

OnSelect (New Form and Edit Form):

Refresh('Time Sheets_1');SubmitForm(DailyForm)

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Data source may be invalid

Nav to your edit form that is getting the ETAG error with this code from the gallery button selector to the edit form:

Navigate(MyEditScreen2, ScreenTransition.None, {SelectedItem: MyBrowseGallery1.Selected})

notice that third optional parm is the list item to gallery super glue.


Put this code in the submit on that form that gets the errors (check box upper right) of the submit form:

Refresh(MySharePointListName);SubmitForm(MyEditForm2)

Highlighted
Regular Visitor

Re: Data source may be invalid

Yes, I've tried that and it's not working, do you have any other suggestions?

 

Session ID: 735551d3-013f-414d-8a34-5eee9cdddee4
PowerApps 3.18075.22

Highlighted
Frequent Visitor

Re: Data source may be invalid

Found out that the problem was related to SharePoint Designer Workflows executed on the list...

I think that, when worflows are launched (when an item in the list is created or modified), the list item definition is changed (obvously) so PowerApps item definition is quite different from SharePoint (source) item. And that is why there is a conflict when i try to update the item inside my PowerApp.

I tried to add some refresh, but that didn't worked at all.

The only solution i've found is to disable all SharePoint Designer Workflows executed on my list, then replace them by Microsoft Flow. Now my Application is working fine !

I'm a bit tired of "Evolutions/Updates" in O365 that broke things wich worked fine...

Highlighted
Anonymous
Not applicable

Re: Data source may be invalid

I just modified a SharePoint OnLine form. I have the same problem! I just added a Toggle to hide a text field...

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (8,617)