cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BCLS776
Super User
Super User

Date not passing correctly from app to flow

I've built an app with a datepicker that sends info, including this date, to a flow that places it in a sharepoint list. The following error is happening:

BCLS776_0-1603332033503.png

The request from the app shows:

BCLS776_1-1603332167857.png

 

The app is expecting to send out a date: 

BCLS776_2-1603332270321.png

The flow is set up to send this to a column in the sharepoint list that is formatted for date-only.

Can anyone tell me why this error is happening and what else I need to do to make this date readable for the flow? TIA.

 

 

_________________________________________________________________________________________
Help the community help more users by choosing to "Accept as Solution" if this post met your needs. If you liked the post and want to show some appreciation, please give it a Thumbs Up.
4 REPLIES 4
v-bofeng-msft
Community Support
Community Support

Hi @BCLS776 :

I'v made a similar test but did no encounted the problem you mentioned.

I suggest you convert the text type parameter ‘triggerBody()?[’Createitem_WorkDate’]’ into a date type in flow and try again.

For example:

formatDateTime(triggerBody()?[’Createitem_WorkDate’])

 2.JPG

Best Regards,

Bof

Hi @v-bofeng-msft ,

I tried the solution with the formatDateTime expression in the flow and the same error continues to come up.
I also tried:
- Disconnecting the flow from the app and re-establishing the connection with a new Run function call

- Replacing the datepicker argument to the Run function call with a Today()

 

The result is the same in all cases: a run-time error for the app attempting to pass a string into a date column. Any other ideas?

_________________________________________________________________________________________
Help the community help more users by choosing to "Accept as Solution" if this post met your needs. If you liked the post and want to show some appreciation, please give it a Thumbs Up.

Got the answer on another thread:

https://powerusers.microsoft.com/t5/Building-Power-Apps/Suddenly-DatePicker1-SelectedDate-does-not-v...

 

_________________________________________________________________________________________
Help the community help more users by choosing to "Accept as Solution" if this post met your needs. If you liked the post and want to show some appreciation, please give it a Thumbs Up.

Update: the problem has recurred, so I'm reaching out to Support now.

_________________________________________________________________________________________
Help the community help more users by choosing to "Accept as Solution" if this post met your needs. If you liked the post and want to show some appreciation, please give it a Thumbs Up.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,838)