cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Deep linking to item

I created an app with deep linking to a specific item and screen. The database is in SharePoint. When an item is created an email is sent out to a specific person with a link to the item and proper screen. 
It works great when I test it but when I have someone else test it the screen they receive states 
"Getting your data" and stays stuck on that screen. 

Anyone have any ideas why this is happening? 

2 ACCEPTED SOLUTIONS

Accepted Solutions

Found my issue. 
My formula was correct. 
I changed the datasource on both forms. 
Because it's a stand alone app with the datasource in SharePoint. Instead of [@SharePointSite] in the datasource section of the form, I changed it to SharePointSite and this seems to have fixed the issue. 
Thank you to all who attempted to help. 🙂

View solution in original post

15 REPLIES 15
Super User III
Super User III

@Lisea123 
Getting your data typically shows when no Item is found in the form.


Two ideas:

#1 Make sure you shared the SharePoint list with them as well as the app.

#2 Maybe you need to confirm the user is able to see the Parameter you passed into the app for ID by putting it in a label temporarily.

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

Members have been added to the app and also have access to the SharePoint site. 
I'm new so not certain how I would do #2. 
Can you elaborate please?

@Lisea123 

How are you telling PowerApps what item to open in the Form.  Please share your code.

OnStart i have

ClearCollect(colQEdata,QualityEventItems);
ClearCollect(colSupervisors,Evaluators);
Set(varScreen,Param("Screen"));
Set(
varEmpID,
Value(Param("EmpID"))
); If(varEmpID <> 0 && varScreen = "Staff",Set(SelectedItem,LookUp(colQEdata,ID = varEmpID));Navigate(DetailScreen,Cover),varEmpID <> 0 && varScreen = "Management", Set(varSelectedManager,LookUp(colQEdata,ID = varEmpID));Navigate(scrnInfoManager,Cover))
 
OnSelect of the button to send the email:
Office365Outlook.SendEmailV2(crdIdentifiedEmployee_Man.Selected.Email, "An ECO for you to acknowledge", "Here is an ECO <a href = 'https://apps.powerapps.com/play/36fccdc3-f0b3-436d-90c5-e1ceb184b609?tenantId=4830d02f-fd7b-4629-905..." & varSelectedManager.ID & "' >link </a> for you to acknowledge." & "</br> Please acknowledge as soon as possible.")
 
and on the Detail screen Items:
SelectedItem

@Lisea123 
Hmmmm... I don't see any problem with your code.

Should I change the varSelectedManager.ID in the Button OnSelect to  selectedItem.ID   because the Details Screen's Items properties is SelectedItem?

@Lisea123 

Sorry, I'm not sure at this point.  I thought I had a path to the solution... but it turns out maybe not 😞

ok 😞 
I'll keep searching. 

Kudo Commander
Kudo Commander

@Lisea123could it be, that the users don’t have access to these list items?

maybe there is a special permission?

i would try it with creating a new screen with all items inside and check if your users can see all entries. I assume you have more permissions because you are site owner?

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (8,067)