cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kmayes
Post Prodigy
Post Prodigy

Default Problem

Hi Community

 

I have an app connected to a SP list I found a set up issue where one of the list fields had a default value which was wrong. Therefore I removed the default value to have no default. However upon testing the app the list is still updating the previously selected default value???

Has anyone come across this i have tried a few options to rectify this even removing the data card from the app and re-adding as a last resort however the issue my be more on the list side as I then removed the card from the patch code and when refreshing the list it is still reverts to the default value?? How?

 

If anyone has any pointers on this it would be much appreciated 

 

Many thanks

 

15 REPLIES 15
zmansuri
Super User
Super User

If there is already value in the field it will show it there until removed. You changed the default value from SharePoint side So it will not  be there for new record.

@zmansuri So i removed the value from the database side re-submitted from power app side and it still changed the value to the default surely that shouldn't happen?

Ramole
Super User
Super User

@Kmayes 

 

Can you post a screenshot of the fields in question ? and your currant code please that a strange 

Thank you
If this post helps, then Click on the Thumbs Up below. and Accept it as the solution . to help others find helpful.

@Ramole  Sure this is the column setup as you can see it is set to none on the default ?

 

Kmayes_0-1631258489968.png

 

@Kmayes 

Are you patching or SubmitForm() 

If patching try the this field   

TheFieldname: {Value: ""}

 

and see what it does 

Thank you
If this post helps, then Click on the Thumbs Up below. and Accept it as the solution . to help others find helpful.

@Ramole I am using patch because the set up requires it. So on my patch it is telling it to patch to that column so ColumnName: CardValue.Selected (which has a yes or no radio button) which should then patch the selected value to the column. The default prior to me changing it was 'Yes' but when patching 'No' it then reverts back to Yes which it shouldn't

@Kmayes 

 

What do you have Item Property ?

Let me ask you what control do you have inside PowerApps, is it Dropdown  or Radio button ?

and what do you have Default of the control not the card ? is it Parent.Default, if yes any error ? If no add Parent.Default and tell me what is telling 

Thank you
If this post helps, then Click on the Thumbs Up below. and Accept it as the solution . to help others find helpful.
Kmayes
Post Prodigy
Post Prodigy

@Ramole Where is the item property?

 

The default of the card is thisitem.columnname and the control is thisitem.columnname.value

@Kmayes 

Radio control itself see the screenshot, to troubleshoot, wipe thisitem.columnname and the control is thisitem.columnname.value, as your patching it should send whatever you selected no matter what is the default in SharePoint. see the above if it doesn't work for you please re step back and see if the patch formula is correct, also if you have another formula on the control itself. the problem is within canvas.

 

Captuxre.PNG

 

Share you currant patch formula. and are this controls inside a form, what is the item property the form etc. 

Thank you
If this post helps, then Click on the Thumbs Up below. and Accept it as the solution . to help others find helpful.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,918)