cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Collector
Kudo Collector

Default form giving error in Items property

Hello, 

 

I have this very strange and very annoing problem with default forms...

I have an app with a default form, and sometimes, with no apparent reason I find this:

 

Image.png

with the message "L'origine dati fornita alla funzione non è valida" (translated in Englis would be something like "The datasource given to the function is not valid")

 

I am using this app, saving it with different names, for twin sharepoint databases (same table names, column names, etc.) and I only get this error sometimes with no aparent reason.

 

Does anyone have any idea why this could happen?

The result of this error is that in app preview everything works fine but when saving and launching the app I cannot access the data.

 

Final Note: this happens with Look Up, Choice and User columns. In this case is a user person connected to a sharepoint user column.

 

If somebody has any ideas to solve this annoying problem, I would really appreciate the help.

 

Thank you, Claudia.

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Default form giving error in Items property

Hi @clau0289 ,

Do you mean that you have "data source invalid" error?

If so, I suggest you check your data source.

You could click "refresh" to refresh the connection.911.PNG

If the problem still exists, I suggest you recreate connection.

 

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Kudo Collector
Kudo Collector

Re: Default form giving error in Items property

Hi @v-yutliu-msft

the error seems to be that one but if I turn the DataCard editable (not default anymore) and just cancel the last ")" in Choices(Project_Eng_Events.Manager) and rewrite it the error dissappears, but not forever... It may come back again but without any logic on it (if I edit the app I might find it or I might not...)

I did refresh the connection, I did reacreate the connection (I do that in every copy of the app) I even recreated the whole form but it still gives me this error. I thought it was a bug in the copies but this error appears algo in the original app...

 

I'm really lost here...

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,583)