cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Default formulae erroring

HI all,

 

I've been having a few problems with powerapps in that simply inserting an object now is throwing back errors in this fasion:

image.png

 

 

The only thing i've changed about this item is on select, to delete the current record which is the only formula contained within that item that isn't failing. Yet colour attributes aren't recognised now, how can they be throwing back errors when the formulae come predefined? 

 

I've been getting other odd errors from another button - i've been trying to submit/resetform and i getting the error "It must be an editable form" despite the fact it evidently is. I fixed it on another button simply by re-ording the commands starting with changing the visibility of a form before resetting it, this isn't working now.

 

What's going on here? It seems powerapps is just being really buggy and i'm not sure why. I've tried adding different buttons and icons and the same errors are happening. 

2 REPLIES 2
Community Support Team
Community Support Team

Re: Default formulae erroring

Hi @Anonymous,

 

Could you please share more details about the error message within your app?

Further, could you please share a bit more about the PressedColor property, HoverColor property, etc of the "Delete" icon within your app?

 

I have made a test on my side and don't have the issue that you mentioned. Please take a try to re-create your app, then check if the issue is solved on your side.

 

In addition, please take a try to enable/turn on the "Render in classic mode" option within Advanced Settings of App settings (App settings-> Advanced Settings-> "Render in classic mode" option), then check if the issue is solved on your side.

 

 

Best regards,

Kris

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: Default formulae erroring

image.pngimage.pngMany errors.gifimage.pngimage.pngimage.png

 

 

 

 

 

 

 

 

 

 

Hi @v-xida-msft - thanks for getting back to me.

 

I've taken a selection of errors that shouldn't be errors above as you can see, but there are too many to do one per error and so a GIF to demonstrate the numerate amount and the types of errors. I've played about with rendering in classic mode and nothing is changing. 

 

I've found that silly things like reording the commands of the error about the editable form not being editable have temporarily fixed those issues, but when re-loading it seems it has reverted to the same error. In a new app - i tried re-creating the same issue. Whilst i couldn't get the same problems, commands like

UpdateContext({visible:false})

 Aren't running when called directly from onselect on a button.. very odd! Rendering in classic mode didn't seem to do anything either.. any ideas?

 

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (3,532)