cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kudo Kingpin
Kudo Kingpin

Delay for updating changes to datasource

I always need to reload the page to update the changes to the data source (New columns, data type, etc...)

I'm using the SQL connector and the "Explicit column" is unchecked.

 

Am i the only one?

1 ACCEPTED SOLUTION

Accepted Solutions
Kudo Kingpin
Kudo Kingpin

The issue is now solved! 

View solution in original post

15 REPLIES 15
Community Support
Community Support

Hi @WPB,

 

It seems that your app is based on SQL Server table.

What’s the function you are using to submit changes to data source?

Could you share more details on the app configuration?

What are the column types in the table?

By the way, I have made a simple test to patch records to SQL Server table, which is always working fine.

Please share more details to help reproduce this issue.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The datatype in the tables doesn't seem to impact. 

There are 2 types of problems really:

Step to reproduce the first one:

1) I go in SSMS, then change the name of a column in a view that is already being used in a Gallery in power apps

2) I test the View in SSMS to confirm that it's working perfectly

3) I go in PowerApps refresh the data source (View->Data Sources -> "..." on the view -> Refresh)

4) I got to the view and try to use the newly named column. This is where the problem is:

          - The new named column doesn't appear in the proposed fields

          - Even if I hard write the new name, it doesn't work

I must wait half an hour sometimes before the new name accessible. It doesn't work if I restart power apps.

 

The other issue is once again with a view:
1) Using the NewForm, I add a new item in a table (This works, I can see the new item in SSMS)

2) I use a view to see the new item (This works as well, I can see the new item in the view in SSMS)

3) When I use Power Apps, I try to see the new item in a gallery that represents the view and there is a problem:

     - Not always but often, it takes 30 seconds for the data in the gallery to update.

I'm seeing the first issue as well in Azure SQL DB (new tables/views and changes to tables/views are not visible in PowerApps for some time). For me the delay is more like 5 to 10 minutes.

Not sure if it makes any difference, but after a change in your database, in SSMS, try refreshing in the database navigator.

@PaulD1 

First, I love your videos!

I tried to refresh but, it has no impact on my part. It's taking more than 2 hours for me now to get a refresh. I created a ticket and it's being investigated at the moment.

Kudo Kingpin
Kudo Kingpin

The issue is now solved! 

View solution in original post

I am having this issue today.  A long delay to refresh after making changes to my SQL table in SSMS.

Now, you can make it refresh instantly by going in View -> Data Source -> selecting your source and refreshing it.

 

This isnt working either.  Still a long delay.

If you want to see the changes you've made to your SQL objects immediately.  Go to Task Manager>Services and re-start the On-premises data gateway.  It works for me immediately all the time.  
- Wes

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (32,624)