cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WPB
Kudo Kingpin
Kudo Kingpin

Delay for updating changes to datasource

I always need to reload the page to update the changes to the data source (New columns, data type, etc...)

I'm using the SQL connector and the "Explicit column" is unchecked.

 

Am i the only one?

15 REPLIES 15
vickywhitmore
Regular Visitor

I am getting the same issue.  I have put the refresh command multiple places in the app to try and force a refresh as I need to get the new data to display straight away.  For testing going into task manager to restart the service is fine, but using it for production wouldn't work as I would need to be refreshing it every two seconds as users are trying to use the app.  Has anyone else found a solution to get it to refresh quickly? 

I haven’t noticed issues with refresh in production. Only during development. I am still having the issue though.

Yes.  Go to Services where your On-premises data gateway is installed. 

Find the On-premises data gateway on the list of services and do a re-start.

Refresh the connection in PowerApps and you'll see the changes.

Francis_Ayson
Frequent Visitor

I am also experiencing the same issue. I refreshed DataSource, Reconnected my SQL Server, cleared my browsing history, and yet i still get the same problem on the delay for updating changes in Datasource. It should not be as difficult as this when refreshing sql database via powerapps otherwise we will be experiencing delays in developing the app as well since we could not find the new column we have added in the datasource. 

I am also seeing this issue recently.

Whilst restarting the gateway service seems to fix the problem, it shouldn`t be required.
This is an issue which never used to happen.

Would be really nice if MS could let us know why this is now happening and how they intend on fixing the issue.

I am sure a lot of people wouldn`t be happy with having to restart a service which is running in production.

fugixi
Resolver II
Resolver II

I can confirm that this problem occurs for other data sources as well.

I currently have a large SharePoint (containing around 13 000 items).

 

My first thought was that there was a delay when refreshing the data source, but the issue seems to rather be with the actual ClearCollect function, which needs to be performed multiple times.

 

This most certainly has to be a bug.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (78,195)