cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Delayed load for PowerApps customized SharePoint forms in PowerApps SharePoint webpart

There's a delayed load of a minute for customized SharePoint forms in the PowerApps SharePoint webpart.

 

The customized form displays with a black screen initially for about a minute and then renders. This is happening for two different apps on two different SharePoint sites.

 

This problem starting happening on 4/30. So there's definitely a performance problem happening with the PowerApps server, service, or infrastructure.

 

See my earlier 4/30 post on related problem:  Apps no longer display using the PowerApps SharePoint web part with app ID: 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

@AnonymousI was informed that there was a performance regression in the published apps which have since then been fixed. Can you please republish your form to pick up the changes?

View solution in original post

8 REPLIES 8
Power Apps
Power Apps

Apologies for this. Would you be able to share a screenshot of what you are seeing and also share the session id?

 

To get the session id, please do Alt + right click on the PowerApp.

 

Thanks

Cherie

Anonymous
Not applicable

@cherie,

 

Here are the two Session IDs:

88f27f47-f7b5-48e5-b219-b5ba0cab9306 

933a0604-c7d4-4c7b-837f-519a8b163ac5

 

and this is what I initially get:

black_screen.gif

 

Community Support
Community Support

Hi @Anonymous ,

Please try the ways in the link that you've listed.

What's more, you could try to recreate the custom form.

Here's a doc for your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-list-form

The information in details is in this paragraph:Delete the custom form

 

 

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi @cherie,

Any updates?   

 

The loading speed has improved a bit with no interference from me so this definitely seems to be a PowerApps infrastructure intermittent performance issue.

 

We're still looking into your sessions

Did you republish your application?

@AnonymousI was informed that there was a performance regression in the published apps which have since then been fixed. Can you please republish your form to pick up the changes?

View solution in original post

Anonymous
Not applicable

@cherie 

 

Definitely better.. thanks 

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (9,244)