cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper IV
Helper IV

Difficulty using azure back end database - sooooo slow

Hi

I have  a databse using Access Web Apps which they now tell us will be discontinued in favour of Power Apps - No Comment !

However I can connect to the Azure back end  in Power Apps  but having great difficulty.

I can connect to a table OK however if I try a clearcollect it either only draws 5 records or in the case of a table with only 5 records i got the 'There is an error on the server' message. I tried addcolumns and the script is accepted without errors but no records returned. I think becuase it is so slow to draw the data . . I am aware that they are going to shut down the azure database and I have to transfer all to a sharepoint list at some stage- However i don't want to do this until I have worked out my app with the existing data.that I can check out using Access Web Apps.

Help !

 

Cheers

Richard

 

8 REPLIES 8
Highlighted
Helper IV
Helper IV

So this is an update ! I created a new gallery with the record souce being an access table with ten entries called 'Progress' . This is a look up table, not supported in Powerapps as lookup so I need a clearcollecr to match the data. I ran this script

ClearCollect(tester,'[Access].[progress]')

on the 'On Hidden' event thinking - well the table muist be in memory so it should work - However the Collection Tester will only run 5 fields. - No blue dots, red dots yellow triangles anywhere - 

The same happens when I put this script in the ON Visible event of the main gallery

Stuck - as I cannot search all records !!

Any suggestions

 

Cheers

 

Richard

Highlighted
Community Support
Community Support

Hi rilmckean,

 

May I know how many records do you have within this connection? If you try to connect to another smaller one, will the issue persist?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hi Mona

I will run a test app using a table with 10 entries only and test it - 

However I am now told by Microsoft that the Azure back end databases for Access Web Apps are going to be closed down so I am now concentraing on sharepoint lists that hav ebeen imported from the Web Apps. . However this is giving me even more problems as you might see from other messages i have posted !

I am begining to wonder if the issues stem form the importing of the data form Azure. many of the taqbles had related fields etc and I wonder if this is what i causing the problems - Although, as stated in my message above, the test I was running was on a list with 20 records only - although other tables were open in the app at the time

Cheers

 

Richard

Highlighted

Hi Mona

So results as follows

Connecting to sharepoint list - new app - Table with 20 records only- Clearcollect collects last record only

test2.JPG

 

Connecting to azure - new app - same table with twenty records - Clearcollect collects first five - see below

test.JPG

Have currently aslo got a thread with Mabel as shee amswered another of my messages on the same topic.

Script is ClearCollect(test,progress.Progress_)

Hopefully one or other of you may be able to sort this out as without a working collection I cannot use any of mt related fields !!!!

Many thanks

 

richard

 

Highlighted

Hi Mona

 

Further update

In exasperation I created manually a new list with only two fields. I created 7 records. I then created a powerapp using this new list - Guess what - the clear collect only brings up 5 items.

There must be something that is preventing full download of all 7 items. I have checked all sharepoint permissions and I have full read/write.

 

PLEASE HELP !!!!!

Sent same reply to Mabel !!

Cheers

 

Richard

Highlighted

Hi rlmckean,

I am in exactly same situation as you. Access web app it will be totaly shutdown  next year, meaning we need to find another server to save our back-end database. You may have a look on Azure - may be a solution.

However, for the front end app, at the moment Power app is not an option. As you can see, no one come with a clear answer, they just try to understand the problem and they come with some funny work arounds.

My opinion - look for different solutions on market - as I am trying to do at the moment. I know is difficult and takes time to learn different systems, but unfortunately Microsoft let us with no viable option.

I am still waiting for Power app to get some support for relational databases - at the moment you can just add info in a spreadsheet using a mobile app. How funny is this?Smiley Happy

Highlighted

How are you verifying only 5 records are returning?

In the "Collections preview" UI we only display a few records since that is only for you to preview the schema of the table and to show a few sample rows.

 

Have you tried binding it to a Gallery and see if you are getting the records? When you do that Gallery will automatically paginate through the records as well.

 

 

Highlighted

Hi

Thanks for that tip - It has verified that I can get a clearcollect to run from a new pristine list of seven items - so its not an inherent issue I have - It must be to do with the data imported into the lists from Azure I believe.

I have run some further tests as follows :

I have currently 6 lists as connections in the test app. I have checked them all against a blank gallery - 4 out of the six will list the full table. 2 out of six will only list the last record.

I then tried a clearcollect(testdata,<list>) on a number of lists and in each case  only  one record was returned into the gallery. An added complication is that for one of the lists, after I had run a clearcollect(testdata,<thislist>), not only did it only show one record in the gallery when <testdata> was  the items property , but when I changed the gallery items property back to <thislist>  this time it only returned one record, the same record that was returned by the clearcollect !

I am suspicious of the imported data as I dont really understand how it works. For instance in one list , there is a <ClientID> which was an original lookup field in Azure. When I view the list in sharepoint , this field does not appear, however when I connect to the list via Access , the field is in the database with the property changed to Number - which is good. Not only that but in Powerapps the field is also available for lookups which is also good - However due to this major issue with pulling reords out its of little use at present !!

Not moving forward on this one yet !

Cheers

 

Richard

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (11,583)