cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tapan_sam
Frequent Visitor

Direct link to SharePoint list item not opening

I have developed custom list form using PowerApps. Now the direct link to an item not opening and it is stuck. I can see the following error message in the browser console, which is very weird for me. It says access to the resource stuck due to CORS issue. Please see the attached screenshot of the error message.

 

console error.png

Any ideas on how to resolve this are welcome. 

1 ACCEPTED SOLUTION

Accepted Solutions

Finally, I was able to solve this issue:

- Due to a bug in PowerApps there is a timing issue when referencing controls across different screens and when PowerApps is embedded into SharePoint the form failed to load

- Once I have removed the control cross-references form started working again...

View solution in original post

3 REPLIES 3
v-xida-msft
Community Support
Community Support

Hi @tapan_sam ,

Could you please share a bit more about issue?

Do you mean that you could not open a specific item using a Direct link to a SP list item?

 

I have made a test on my side, and don't have the issue that you mentioned. The Direct URL link I used as below:

https://xxxxxx.sharepoint.com/sites/PowerApps/Lists/20190325_case13/DispForm.aspx?ID=1&pa=1&e=kncZ6P

Based on the error message that you mentioned, it seems to tell that there is something issue with the authentication within the request.

On your side, please consider take a try to clear cache of your browser, then sign in your SharePoint, try your Direct link again, check if the issue is solved.

Please also check and see if the following link would help in your scenario:

https://crunchify.com/how-to-fix-access-control-allow-origin-issue-for-your-https-enabled-wordpress-...

 

If the issue still exists, please consider submit an assisted support through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for looking into this.

 

Yes, you are right. Not open a specific item using a Direct link to a SP list item. Example of the link: {tenant url}/teams/{site url}/Lists/teamactivities/DispForm.aspx?ID=252&ContentTypeId=0x0100DDBB2814281D7A4DB09A99DDEF6204DB

 

The 'loading spinner' is only being displayed. And if I check the internet explorer console lots of PowerApps .css files are blocked due to mime mismatch Smiley Mad . Internet explorer Console and network log is attached for your reference.

 

I have already tried to clearing the bowser cache and all but no luck.console.jpgnetwork log.jpg

 

Thanks.

Finally, I was able to solve this issue:

- Due to a bug in PowerApps there is a timing issue when referencing controls across different screens and when PowerApps is embedded into SharePoint the form failed to load

- Once I have removed the control cross-references form started working again...

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (54,389)